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About This Book

Subject This book provides tutorials for learning to use InfoMaker. The tutorials
introduce InfoMaker and teach how to create forms, reports, queries, and
graphs. The last tutorial puts everything into an InfoMaker application.

Audience This book is for new users.

Online Hel When you have a question about using InfoMaker, you can access its
y q g y
online Help system. You can also access the Powersoft Online Books,
which consist of all InfoMaker documentation in electronic form.

vii
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L Roadmap to InfoMaker Documentation

Installation and tutorial
3 Installation Guide
£Q  Getting Started

Using InfoMaker
3 User's Guide

Communicating with a database
£ Connecting to Your Database

How to use the
Powersoft Online Books

See the Using the Powersoft Online Books

How to order printed
documentation sets

Call 1-800-8-SYBASE

The Answer Page
For resources to help you get answers to questions
you have about Powersoft products, use the
Answer Page in InfoMaker online Help
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InfoMaker documentation

These are the books in the InfoMaker documentation set, grouped by

topic:

Topic

Manual

Description

Installation and
tutoriai

Installation Guide

Provides instructions for installing
InfoMaker

Getting Started

Introduces you to InfoMaker and
provides a tutorial you can step
through to learn the basics

Using InfoMaker

User’s Guide

Tells how to use InfoMaker to
create reports, work with databases,
transfer data between databases,
create forms to update data, create
queries to automatically retrieve
data, and create applications to
package reports and forms

Communicating
with a database

Connecting to
Your Database

Tells how to connect to a database
from InfoMaker; describes how to
set up, define, and manage database
connections accessed through the
Powersoft ODBC interface or one
of the native Powersoft database
interfaces
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InfoMaker documentation packaging

Book Packaging
Installation Guide XP

Getting Started X P
Connecting to Your Database XP

User’s Guide X

Key to symbols
Symbol | Means

X The book is applicable and provided on the InfoMaker 6.0 Online Books CD

P The book is provided as a printed book in the box

No Arabic and Hebrew
InfoMaker is not available in Arabic and Hebrew versions.



CHAPTER

1

Welcome to InfoMaker

InfoMaker is a powerful yet easy-to-use reporting and data maintenance
tool that lets you work with data in the Windows environment.

With InfoMaker you can create sophisticated forms, reports, graphs,
crosstabs, and tables, as well as applications that use these as building
blocks. You can also move data between databases using the InfoMaker
data pipeline.

This chapter introduces InfoMaker and describes:
¢ Starting InfoMaker

¢ Using the tutorials

¢ InfoMaker samples

The rest of the chapters are tutorials.
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What you make with InfoMaker

Forms

Reports

Total Compensation RePOrt | e of peats ins. = 54,500 pa“: ;;fg;
Sa|ary P|us Beneﬁts Value of life insurance = $(5.43 x sataryy1,000
Vatue of day care = $5,200
Department Employee Employee Employee Salary Health Life Day SalaryPlus
D D First Name Last Name Ins. Ins. Care Benefits
100 102 Fran Whitney $45,700 FF $50,748
$62,000 2

105 Matthew

Rodrigo

Ram

Terry
316 Lynn
445 Kim

453 Andrew

Guevara $42,998
Gowda $59,840
Melkisetian $48,500
Pastor $74,500
Lull $87,900
Rabkin $64,500

U U U

aRanan

$48,031
$60,165
$58,763
$84,905
$93.177
$69,650
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Crosstabs Number of employees by Total number of
department and salary employees making
the salary
B0,000 includes up to 39,999
Dept Id
Salary. 100 200 300 400 500
20000 2 s 7
30000 3 8 2 5 2 20
46600, 5 5 2 5 1 19
50000, 4 3 3 2 q 13 ]
60000, 4 1 2 7
70000; 2 1 1 4
80000; 2 1 3
30000 1 1
130000 1 1
Total number of employees 22 18 g 16 g
n the department
Reports with nested 1239 Customers and Orders
reports
Customer Information Order History

Customer ID: 105
First Name: Laura Sales OrderDate Sales Line # Product Quantity  Date
Last Name: McCarthy L Rep i ° Shipped

Address: 1210 Highway 36 | 2
City: Carmel
State: IN
Zip Code: 46032-
Phone Number: (317) 555-8437
Company Name: Amo & Sons
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Composite reports

Forms with reports

3123188 Quick Reference Information
Productsand Current Inventory ‘Sakes Representstives and Totsl Number of Orders
Product Product Product wit aneer | | saies Sy ot
D Name Doscrigton Price InStock | | ReBID  wame Prare Ordrs.
06 TeeShm  TankTop sec0 2 122 emip Chin @Mt 67
301 TeeShm  Vaack 400 S 195 warc oml ©Iness24e 5o
0z TeeSMR  Crew Weck FITY S S 200 Rollin Cvemey G107 114
406 Baseball Cap Comon Cap sone 12 467 James Kicbucher Tyt s
401 BaseballCap Wool cap soge 12 67 wany urca TInessMUM s
see  Visor Cloth Visor o % 60 atoen Polgas ®messwn 2
501 Viser Plastc Visor oo 3 256 Samual Singer SIS 55
€00 Sweashi  Woooes Swedshin  F240C 1 202 won selly e seITee o7
661  Sweashin  Tppeu Sweashin 52400 32 0 mamcla Savaeo (105551857 53
76 Shors Comen Shors ss0e % 1442 Alison Clak G105 57
1506 Camatine Picken ©messure 53
Praduct Soks Sumemary Sales Summary
Mg I, Y, |
M0 TeeSMR  TankTop 2%4 321216 wodt cap
Vneck
W Teedh  vaeck 2188 3man Tank Top
M2 TeeShik  Crow heck 2148 3l0p72 Pasdc Visor
45¢  Baseball Cap Comon Cap 38 329502 | mooaea Sweasshin:
461 Baseball Cap Wodl cap. 1 sarere Crow ack
0¢  Viser Cloth Visor 2662 B13564 Comon Shors:
s61 wisor Blasdc Visor 206 BITSEE Comon Cap
600  Gweamhin  wo00ea SWeIGMIR 3060  FTIA4L Clom Visor
601 GwodsMm  Zpped Gweashin 2724 365,376 ¢ oo ddeo  cwdeo  sadae
T Shors ComnShons 4536 $68040

£) Maintain Contact Information
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Graphs
P Contacts by Job Role
B Administration 667% 5.00%
BB  cCustomer support
Documentation
Finance 25.00%
EE  Human resources
B Marketing
Hl  Other
BB Product development
I soes
EER Training 1667%
167%  10.00%
Reports with graphs
Breakdown of Salary Expenses for 1998
Department Total Salal
partme i Salary Expense by Department
Finance $535,500.00
Marketing $698,250.75 Shipping
R&D $1,292,198.19
Sales
Sales $919,428.00 §
Shipping $303,769.80 g R&D
Marketing
Finance
) S00000 1000000 1500000
Total Salary
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Labels
Alex Ahmed Joseph Barker Irene E
114 Cushing Street 58 West Drive 37 Gle:
Needham, MA 02192 Bedford, MA 01730 Bedfon
—
Jeannette Bertrand w Janet Bigelow Barbar
208 Concord Street 84 Lunda Street 66 Bea
Acton, MA 01720 Waltham, MA 02154 Needh
Jane Braun Robert Breault Matther
45 Wood Street 58 Cherry Street 57 Tayl
Cambridge, MA 02140 L Milton, MA 02186 Lexingl
I—
>
Joyce Butterfield Shih Lin Chao Doug ¢
119 Adams Street 59 Holyoke Street 57 Wet
Cambridge, MA 02140 Lexington, MA 02173 Concol
Applications

Contacts

et

_prompting

Id | Last Name First Name Job Role Street
5 Sullivan Dorathy  {Customer support 54 Minutemnan Dr.
12 {Lyman Thomas _ {Customer support 64 Story Rd.
16 iLencki John Customer support 208 Brook Road
1¢  |Hayne William Customer support 38 Cornfield Ave.
21 {Cobh Paul Customer support 34 Greenville St.
22 iGoodin Kevin Customer supnort 88 East Main St.
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Starting InfoMaker

These instructions assume that you have already installed InfoMaker.

FOR INFO  For information, see the InfoMaker Installation Guide.

e

¢

% To start InfoMaker using the Windows 95 Start menu:

Display the Start menu, select Programs, then Powersoft, then
InfoMaker 6.0, and then InfoMaker. The InfoMaker initial screen
displays.

The initial screen includes the PowerBar, which has buttons for
accessing the InfoMaker painters. To access a painter, click the
appropriate button.

If you are using Powersoft Online Books

If you are doing the tutorial using the online version of this book, you
may want to select a view that will automatically display all graphics
(instead of showing them as icons). To display all graphics, select
View>Main>SHOWALL from the menu bar in Powersoft Online
Books.
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Using the tutorials

Requirements To use the InfoMaker tutorials, you need:
¢ To be connected to the Powersoft Demo Database

¢ To have the sample library named TUTOR_IM.PBL open

Approximate times

Tutorial Chapter | Minutes
InfoMaker Basics | 2 15
Form 3 45
Report 4 45
Table 5 45
Query 6 15
Graph 7 30
Environment 8 30
Application 9 30
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InfoMaker samples

The InfoMaker sample library named TUTOR_IM.PBL is the library you use
in the tutorials. TUTOR_IM.PBL includes sample reports, forms, a sample
query, and a sample pipeline. After you have finished with the tutorials, you
may want to look at these samples to learn more. Many of the samples are
discussed in the InfoMaker User’s Guide.



InfoMaker samples
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CHAPTER 2

InfoMaker Basics Tutorial

The InfoMaker world is a friendly and efficient environment for you to
work in. It provides features such as movable toolbars, popup menus and
property sheets, lasso selection of objects, and more.

In this tutorial you will learn the basic skills you need to work in
InfoMaker.

Total Compensation RepOrt | v.u. v seats ins. - seam0

sahry Plus Benefits Vaive af life mewrarce ~ $(5.13 x ealory/1,000
Value of day ~are =$5,200

Day SalaryPlus
Benefits

Heattl
First Name Last Name ins.
Mary Garcia et 2 $4£216
Kathieen Poitras i H $4€,451
Samuel ¥

3T

Taylor
Pamela savarina $72,330 v 2 $77,493
Paul Sterling $64.930 % " $7£.252
Shih Lin Crao $33,830 ; i T $35,274

How long will this tutorial take?
About 15 minutes.

1
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Start InfoMaker

Now you will start InfoMaker.

¢ Display the Windows 95 Start menu, select Programs, then Powersoft,
then InfoMaker 6.0, and then InfoMaker.

The InfoMaker initial screen displays. It includes the PowerBar, which
has buttons for accessing the InfoMaker painters and online Help.

If you are using Powersoft Online Books

If you are doing the tutorial using the online version of this book, you
may want to select a view that will automatically display all graphics
(instead of showing them as icons). To display all graphics, select
View>Main>SHOWALL from the menu bar in Powersoft Online
Books.

12



Chapter 2

InfoMaker Basics Tutorial

Access painters

Where you are

Start InfoMaker
> Access painters
Use toolbars
Use popup menus and property sheets
Use the mouse with objects

What click means

The word click is used throughout these tutorials to mean move the pointer
somewhere and press the left (primary) mouse button. For example, click

the Report painter button.

1 Click the Report painter button in the PowerBar.

InfoMaker connects to the Powersoft Demo database, which may take a

minute or two.

Then the Select Report dialog box displays. It lists the reports in the
current library, which is the library named TUTOR_IM. This library
includes samples that come with InfoMaker and is the library you will

use for the tutorials.

If the current library is not TUTOR_IM

If the current library is not TUTOR_IM, you need to change to it.
Select File>PowerPanel from the menu bar. Select the Environment
painter. In the Environment painter, select File>Open and navigate to
TUTOR_IM.PBL in the TUTORIAL folder (in the folder structure

where InfoMaker is installed).

13



Access painters

2  Click expenses (scroll the list until you see the report named
expenses).
Click the Design button.

) | pho_atlribu!es
total_compensation
ee_grouped_salan

utorial: Used for tutorial. Expenses for years
9951997

The design version of the report displays in the Report painter
workspace. You will learn about the workspace in the Report tutorial
when you create a report. For now you will learn basic skills.

todayl()
Expenses for year ‘Page * + page(

quart amoun’

14
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Use toolbars

Where you are

Start InfoMaker
Access painters
> Use toolbars
Use popup menus and property sheets
Use the mouse with objects

InfoMaker comes with three toolbars: the PowerBar, the PainterBar, and the
StyleBar. You can control whether individual toolbars display and where they
display. You can also choose whether to display text in the toolbars.

In this section you will learn how to use toolbars.

(You can also create your own toolbars and customize toolbars, but this tutorial
will not cover these advanced activities.)

1 Move the pointer to any one of the buttons in the PainterBar.
Click the right mouse button.

The popup menu for the toolbars displays.

today()
xpenses for year ‘Page ' + page(

quart _amoun

sum(ar
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Use toolbars

16

About the popup menu

Throughout InfoMaker, popup menus provide a fast way to do things.
The right mouse button accesses the popup menu. The menu changes
depending on the painter you are in and where you are in the
workspace when you click the right mouse button.

Select Floating from the popup menu.

The PainterBar changes to a floating toolbar.

Move the pointer to the title bar and drag the floating toolbar to
another location.

How to drag the toolbar

Press and hold the left mouse button. While holding the button, move
the mouse (an outline displays to show the current location of the
toolbar). When the toolbar is where you want it, release the mouse
button.

today()
Expenses for year ‘Page * + page(

You can put toolbars in different locations: left, top, right, bottom, and
floating.

Select Window>Toolbars from the menu bar.
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About the notation Window>Toolbars

Throughout the tutorials, commands issued from the menu are shown
as a sequence of choices separated by arrows. For example, to select
Window>Toolbars means to select Window from the menu bar and then
Toolbars from the menu items.

The Toolbars dialog box displays. Notice that the PowerBar is
highlighted. If the PowerBar is currently displayed, the middle button
says Hide.

Click Hide.

The PowerBar disappears from the InfoMaker window. The word Hide
changes to Show.

Click Show.

The PowerBar displays again and the word on the button changes to
Hide.

Click PainterBar1 and then click the Bottom button.

The PainterBar displays at the bottom of the workspace.

17



Use toolbars

8 Click Show Textto make text display on the buttons.
Click the Close button to close the dialog box.

Small Fonts

9 Move the pointer over one of the toolbar buttons.

After a couple of seconds, the PowerTip that tells what the button does
displays.

18
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10 Click the small black triangle next to the Text button in the
PainterBar.

The Objects dropdown toolbar displays. It holds buttons for the objects
you can add to reports (a text object is one type of object you can add
to a report). Several buttons have small black triangles. These buttons
belong to other dropdown toolbars (for example, the Border dropdown
toolbar).

today()
Expenses for year ‘Page * + page(

11 Click in the white space to the right of the toolbar to make the
Objects dropdown toolbar close.

Now you know several ways to move the toolbars and you know how to turn
text display on and off.

For the rest of these tutorials, you should move the toolbars where you like to
have them. Your screen may not match the pictures in this book, depending on
where and how you display toolbars.

19
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Use popup menus and property sheets

20

Where you are

Start InfoMaker
Access painters
Use toolbars
> Use popup menus and property sheets
Use the mouse with objects

Now you’ll take a look at popup menus and property sheets. In all the
InfoMaker painters, popup menus and property sheets help you work quickly.

1 Move the pointer to the words Expenses for.
Click the right mouse button.

The popup menu for a piece of text (also called a text object) displays.
Whenever you position the pointer on something that has a popup
menu and click the right mouse button, the appropriate menu items are
listed.

| = Report - expenses

today(
‘Page * + page()

Amount
in thousands

description

quart amoun’
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Select Properties from the popup menu.

The property sheet for the Expenses for text object displays. It has five
tabs, which identify five pages of information. The General page is on
top.

About property sheets
A property sheet is a collection of information about an object. You use
an object’s property sheet to find out and set properties.

For example, a text object has properties such as font, font size, location,
border, and so on. You can see the current settings for these properties on
the object’s property sheet. You can also change them there.

Click Cancelto close the property sheet.

21



Use popup menus and property sheets

4 Position the pointer on the word description.
Click the right mouse button to display the popup menu.
Select Properties from the popup menu.

The property sheet for the data column (Column object) called
description displays. The property pages and options are different from
those in the property sheet for the text object. The Column Object
property sheet is designed for the data column.

olumn Object

22



Chapter 2 InfoMaker Basics Tutorial

5 Click the word Font on the font tab.

The Font page comes to the front of the property sheet.

1 (;,o.lun.'lr‘)“l_]bie’c! B

Arial Narrow

Arial Rounded MT B
Book Antiqua
Bookman Old Style
Braggadocio

[ Transparent

23



Use popup menus and property sheets

6 Click the font size 74 in the Size box.
Click the Apply button.

The Font size of the text object changes to 14. When you click Apply,
InfoMaker applies the change you just made to the object and leaves
the object’s property sheet open.

7 Click the font size 710in the Size box.
Click the OK button.

When you click OK, InfoMaker applies changes and closes the
property sheet. The Font size of the text object changes back to 10.

24
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Use the mouse with objects

Where you are

Start InfoMaker

Access painters

Use toolbars

Use popup menus and property sheets
> Use the mouse with objects

Now you will move some of the objects in the report. Be sure not to save the
changed report, because you will use the original report later. When you leave
the Report painter, you will be prompted to save changes. The instructions will
remind you to say no.

1 Select Design>Options from the menu bar.

In this property sheet, you will turn on some design options that make
it easier to work with objects in reports.

25



Use the mouse with objects

2 Select the Show Grid checkbox.
Select the Show Ruler checkbox.
Select the Show Edges checkbox.

] Report Options

3 Click OK.

Now edges display around the objects in the report, and a grid and ruler
display in the Report painter workspace.

&5 Repoit - expen

26
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Click the text object with the text Expenses for.

Black boxes in the corners mean the object is selected.

Press and hold the CTRL key.
Click the year box and the Amount in thousands box.
Release the CTRL key.

Now you’ve selected all three objects.

- i thousands il

Press and hold the LEFT ARROW key until all three objects are on

the far left of your screen.
Release the key.

27



Use the mouse with objects

28

Move the pointer to the word Expenses.
Make sure the objects are still selected.
Press and hold the left mouse button.
Drag all the objects to the right.
Release the mouse button.

While you are dragging, gray boxes will show the current position of
the objects.

When you release the mouse button, you drop the objects where the
pointer is currently positioned. Notice that the objects are still selected
as indicated by the little black boxes.

Click in an unused area to deselect the objects.

The objects are no longer selected (the black boxes are gone).
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10

1

12

13

Press and hold the left mouse button.
Drag the mouse diagonally down and to the right until the box
surrounds or touches all three objects.

Release the mouse button.

All the objects are selected. This is called lasso selection. You can use
this lasso technique to select many objects quickly. Then you can move
them all together or change something about them all at once.

Press the DELETE key.

The three selected objects are deleted. But you really didn’t mean to
delete them.

Select Edit>Undo Clear from the menu bar.

The deletion is reversed.

About Undo
You can undo the most recent operation on objects in the Report
painter workspace.

29



Use the mouse with objects

14 Select File>Close from the menu bar.

InfoMaker displays a message box to see whether you want to save the
changes you’ve made to the expenses report. You do not want to save
changes. You will use this report later in the Graph tutorial.

15 Click No.

The Report painter closes. Now you are ready to learn how to create a form.

30



CHAPTER 3 Form Tutorial

This tutoriai requires the Form painter

The Form painter component of InfoMaker is optional; you must have
installed it to do this tutorial.

Forms display data and provide a way to interact with the database. You
can use forms to view information and to change it.

In this tutorial you will create a form that updates the contact table. The
form includes:

¢ All columns in the contact table

¢ Buttons for maintaining contact information

¢ A report that provides access to all the information in the contact
table

How long will this tutorial take?
About 45 minutes.
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Create the basic form

Create the basic form

Where you are

> Create the basic form
Preview (run) the form
Save the form
Add buttons to the form
Enhance the form
Use the form to update the database

Now you will create the basic form. To do this you select a predefined
InfoMaker form style and the data to be displayed in the form.

1  Click the Form painter button in the PowerBar.

Your PowerBar may not match this one. It doesn’t matter. You just
need to use the Form painter button.

The Select Form dialog box displays. It lists the forms in the current
library (TUTOR_IM) and has a New button for creating new forms.

ustomer_|

ustomer_maintenance
lepartments_and_their_employees
mployee_data

ample: Master/detail many-to-one form. The
master part is a list of company names and
Ds. Select a company and look in the detail

2 Click New.

The New Form dialog box displays. It contains the data sources and the
form styles you can choose.
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| New Form

About data sources
Quick Select is for simply choosing columns and specifying selection
criteria and sorting, which is what you want for this tutorial.

SQL Select is for using other SQL options not available with Quick
Select.

Query is for specifying the name of a query that describes the data source.
You define queries in the Query painter.

About form styles

A form style is a predefined way of presenting and processing
information on the form. Usually the style includes the common
database functions (insert, delete, and update).

InfoMaker comes with a set of form styles. PowerBuilder users at your
site can create additional styles, which will also display in the New Form
dialog box.
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Create the basic form

34

Click Quick Select and Free Form to select them (the words are
highlighted).
Click OK.

The Quick Select dialog box displays. In this dialog box you select the
table to use and the columns you want included in the form.

Quick Select
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Click contact in the Tables box.

The contact table’s columns display. You will include all columns in
the form.

Quick Selec
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Create the basic form

5 Click the Add All button.

All columns are selected. They display in a grid at the bottom of the
dialog box.

First Name

You could reorder columns and enter sorting and selection criteria in
this grid. But for your form you do not need to do any of these things.

36



Chapter 3 Form Tutorial

Click OK.

Your form displays. It uses the columns and form style you selected.
The text labels come from the repository. Instead of data, the names of
the database columns appear where the data values will be displayed.

nfoMaker

Form - (Untitled)

The repository

The repository stores information about data such as labels and display
formats. When you create forms and reports, InfoMaker uses repository
information to create the basic form or report.

You put information into the repository using the Database painter. For
example, in the Table tutorial you define the label Job Role: for the title
column. Then when you use the title column in a form or report,
InfoMaker uses the label Job Role:.

37



Preview (run) the form

Preview (run) the form

Where you are

Create the basic form
> Preview (run) the form
Save the form
Add buttons to the form
Enhance the form
Use the form to update the database

Now you will preview the form. Running the form is the way you preview it
while you are designing it and the way you use it when you have finished
designing it.

Click the Run button in the PainterBar or select Design>Run from
the menu bar

InfoMaker runs your form, which includes going to the database and
retrieving data.

Notice that real values have replaced the column names in the form.
The PainterBar now has buttons that let you view and change data.

Now you will view the data using the form.
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2 Click the Next button.
Click the Last button.
Click the First button.

This moves you among the rows. Later in this tutorial you will insert a
new row.

Click the Close button in the PainterBar.

You return to the Form painter workspace.

39



Save the form

Save the form

Where you are

Create the basic form
Preview (run) the form
> Save the form
Add buttons to the form
Enhance the form
Use the form to update the database

Now you will save the form and give it a name.

Click the Save button in the PainterBar.

The Save Form dialog box displays with the pointer positioned for you
to type a name for the form.

2 Type contact_maintenance.
3 Click in the Comments box and type This form updates my contact

table.

(Your list of forms may be different from the list shown here.)

Save Form

r_dh
customer_list
customer_maintenance
departments_and_their_employees
employee_data

This form updates my contact table.

4 Click OK.

InfoMaker saves your form.
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About saving

Anytime you have completed a unit of work, you should save. To save,
select File>Save from the menu bar or click the Save button or press
CTRLH+S.
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Add buttons to the form

Add buttons to the form

42

Where you are

Create the basic form
Preview (run) the form
Save the form
> Add buttons to the form
Enhance the form
Use the form to update the database

Now you will add three buttons to the form. Later when you run the form, you
can click the buttons to add and delete contacts.

About controls
The items you see on a form are called controls. For example, a button is a
type of control.

The controls you can use on a form are listed in the Controls menu and are
represented by buttons in the PainterBar. To see the list of controls, click
Controls on the menu bar.

1  Select Controls>CommandButton from the menu bar.

2 Move the pointer to an empty area of the form and click.
If you need to move the button, drag it.
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How to drag

Position the pointer over an object, and press and hold the left mouse
button. While pressing the button, move the mouse until the object is
where you want it. Then release the mouse button.

A button with the text none displays. The text none also displays in a
text box in the StyleBar.

If the text box does not display
This means the button is not selected. To select the button, click it.
Small black boxes in the corners indicate that it’s selected.

Make sure the button is still selected.
Type Add a contact.

The text displays on the button as you type and in the text box in the
StyleBar.
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Add buttons to the form

4 Click B (for bold) on the StyleBar.

: Form - contact_maint,

The text displays in bold. Next you will make the button work. To do
this you will associate an InfoMaker action with the button.

Using the StyleBar

You can use the StyleBar to change text fonts, font size, and style
(bold, italic, and underline). You can also use it to specify text
alignment (left-aligned, centered, and right-aligned).

To use options on the StyleBar, you select a control with text and then
click the appropriate button on the StyleBar.
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Move the pointer to the Add a contact button.

Press the right mouse button to display the popup menu for the
button.

Select Action from the popup menu.

The Select Action dialog box displays. It lists the actions you can
assign to the button.

About InfoMaker actions
An action is what you want to happen when the button is clicked.

Whenever you associate an InfoMaker action with a button, InfoMaker
creates the code to enable the button to perform the action. You do not see
the code. All you have to do is select the action for the button.

InfoMaker comes with predefined actions. PowerBuilder users at your
site can create additional actions, which will also display in the Select
Action dialog box.
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Add buttons to the form

6 Scroll through the list of actions and double-click Insert_Row.

First_Row

Import_File

InfoMaker creates the code that enables your Add a contact button to
display a blank form so you can add information for a new contact.
You will see the button work later.

Now you will add two more buttons.

7 Select Controls>CommandButton from the menu bar.

Move the pointer below the Add a contact button and click.

Type Delete a contact.
Display the Delete a contact button’s popup menu and select Action.
Select the action Delete_Row from the Select Action dialog box.
Click OK.
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Select Controis>CommandButton from the menu bar.

Move the pointer below the Delete a contact button and click.
Type Save changes.

Display the Save changes button’s popup menu and select Action.
Select the action Update_Row from the Select Action dialog box.
Click OK.

Now you have three buttons. InfoMaker has created the code that
enables the buttons to work.
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Enhanée the form

Enhance the form

48

>

Where you are

Create the basic form

Preview (run) the form

Save the form

Add buttons to the form

Enhance the form

Use the form to update the database

In this section you will:

*

¢
.
*

Add atitle

Change the background for data
Move the buttons

Add a report



Chapter 3 Form Tutorial

Add a title

Move the pointer to an unused area of the form and click the right
mouse button.

The popup menu for the form displays.

About the popup menu

When you display the popup menu, the contents of the menu changes
depending on the position of the pointer (on a control, on an unused
area of the form, or on an unused area of a toolbar).

To see this, move the pointer to different places and display the popup
menu.

Select Properties from the popup menu.

The form’s property sheet displays. The General tab is on top.

3 Type Maintain Contact Information in the Title box and press ENTER.

The title does not display now. When you run the form, the title will
display.
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Enhance the form

Change the background for data

Now you will change the background for all data values to be white. This will
make it easier to enter data. You will use lasso select to select the objects.

1 Move the pointer near the bottom of the data and on the right.

2  Press and hold the left mouse button and drag diagonally to the
left and up until the white box (the lasso) touches all the data.

3 Release the mouse button

All the objects inside the white box are selected. Black boxes display in
all the corners.
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4  Move the pointer to the Background Color (Bg Cir) dropdown
toolbar.
Click the arrow to display the color menu.
Click the plain white box (not the white box with the letter w in it).

All the areas on the form used to display data values now have white
for a background color.
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Enhance the form

Move the buttons

Now you will move the buttons to make room for the report you are about to
add.

1 Select a button.
(You can use lasso select or click one.)

Small black boxes in the corners mean it is selected.

2 Drag the button to the top of the form.
Select and drag the other two buttons until your form looks like
this.

Now the buttons are near the top of the form. There is more room for
the report you are about to add.
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Add a report

Now you will add a report to provide information when you are working with
the form. You can scroll in the report while you are filling out the form for a
new contact. This means, for example, that you could look up an area code or
zip code if it’s already present for another contact.

1 Select Controls>Report from the menu bar.

Move the pointer into the workspace. Where you next click will
position the report that you are adding to the form.

2 Move the pointer to the empty space on the right part of the form
and click.

The box that will hold the report displays on the form.

3 Move the pointer to the box and display the popup menu.
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Enhance the form

4 Select Properties.
The property sheet for the box displays.

You will use this property sheet to specify a few things about the
report. First you are going to select the report whose contents display in

the box.
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Click the Browse button.

In the Select Report dialog box, scroll the list of reports.
Select contactgrid and click OK.

elect Report

posite._|
composite_sales_reps
contact_n_up

cstovswith nested_orders
d_dddw_cusl

Next you will specify that the report is to have the Resize border,
scrollbars, and the ability to be resized when you run the form.
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Enhance the form

6 Select Resize from the Border dropdown listbox (you’ll have to
scroll the list).
Select the HScroll Bar and VScroll Bar checkboxes.

Report

7 Click OK.
The report looks like this.

When you run the form, the report displays as a resizable window with
horizontal and vertical scrollbars. This gives you flexibility in looking
at data while working on the form.
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Resize the report to show more data.

To resize, move the pointer near an edge until the pointer becomes
a double-pointed arrow.

Then press the left mouse button, hold, and drag.

This determines the size and position of the window when you start
running the form. Because it is resizable, you can change the report
window while you are running the form.

When you finish resizing, the report should look something like this.
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Use the form to update the database

Use the form to update the database

Where you are

Create the basic form
Preview (run) the form
Save the form
Add buttons to the form
Enhance the form
> Use the form to update the database

Now you will use the form to add a new contact to the database.

1 Select Design>Run from the menu bar.

Your finished form displays with data in place. The report on the form
gives you a way to see all your contact data.
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2 Click the Add a contact button in the form.

An empty form displays. You will use this form to enter a new contact.

formation

The cursor is in the Id box, but you don’t know the next available
number. You will look in the report to see what number was used last.

3 In the report window, use the scrollbar to scroll down to the last
row of the report and check the value in the /d column.

If the data has not been changed since installation, the value will be 60.
So the next available number is 61.

Id | Last Name !First Name|  Job Role

49 John Sales 93 La
§0___iShishov Iring Marketing 567 P
51 __|Trayers Ken Sales 234 He
52 iLong Peter Training 78 Gr:

53 Tippet Debbie Customer support 85 Abe
54 iHodson Jack

5 iKosko KKim

56 McEvoy Jim Sales 23 Hal
57 . iGoodall Sandra___ iSales 56 Surm
58  Elkins John Training 899

Masalsk Kurt Customer support 29 Gar
ryBeth i
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Use the form to update the database

5 Press TAB and type Carter for Last Name.
Press TAB and type Jimmy for First Name.
Press TAB.

At this point you are on the Job Role box. In this box you cannot type.
You must select a job role from a list of possible ones.

In the Database painter, the column was defined to be associated with a
DropDownListBox edit style. The repository stores this and other
information about data.

6 Click the down arrow on the dropdown listbox to display the
choices.

7 Select Marketing.

8 Press TAB and type Peanut Way for Street.

9 Press TAB and type Atlanta for City.

10 Press TAB and select GA for State (another dropdown listbox).
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11

12

13

Press TAB.
To determine what to enter for Zip, scroll the report until you find

another Atlanta entry.
Then click the Zip box in the form and type the zip code you see in

the report.

€ Maintain Conta

Press TAB and type 4045557833 for Phone.

Notice that you type only the digits. The form formats the phone
number. An Edit Mask edit style was defined for this column to handle
the formatting. This edit style is stored in the repository.

Press TAB and type 4045554291 for Fax.

This is what your screen should look like now.
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Use the form to update the database

62

14

18

19

Click the Save changes button in the form to update the database
with the new contact.

The database is updated.

Note that the report always displays the information from the database
when you start running the form. If you update the database, the report
does not show the updates. To update the report, you return to the
workspace and rerun the form.

Click the Close button in the PainterBar to return to the Form
painter workspace.

Click the Run button again and scroll the report to the 61st row in
the report.

Notice that your report has been updated.

Click the Close button in the PainterBar to return to the Form
painter workspace.

Select File>Close from the menu bar.

If you haven’t already saved the current version of the form, you will
be prompted to save changes.

Click Yes.

This closes the Form painter. You return to the PowerBar.



CHAPTER 14

Report Tutorial

Reports display and summarize data. You can view reports on the screen
and print reports on the printer.
In this tutorial you will create a report using the data in the contact table.

The report you create groups contacts by job role and lists phone and fax
numbers for each contact.

This is what the report will look like when you have finished.

Report - contacts_by_jobrole

3/14/98 My Contacts
Last Name First Name Phone Fax
Adminztration
Brier Michael (617)555-2398 (617)555-3337
Lambert Teny (617) 555-2246 (617) 555-3692
Romeo John (310) 555-4533 (310)555-1233
Lustomer support
Cobb Paul (404) 555-2233 (404) 555-8111
Cohen Paul (617) 555-8883 (617)555-4439
Collins MaryBeth (617)555-1193 (617) 5559586
i (713)555-3340 (713) 555-9211
(508} 555-7780 (508) 555-4422

How long will this tutorial take?
About 45 minutes.
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Create the basic report

Create the basic report

Where you are

> Create the basic report
Preview the report
Save the report
Set up the design environment
Define sorting and grouping
Enhance the report
Print the report

Now you will create the basic report. To do this you select a report style and
the data to be used for the report.

1 Click the Report painter button in the PowerBar.

InfoMaker

The Select Report dialog box displays. It lists reports in the current
library (TUTOR_IM) and has a New button for creating new reports.

Seiecl Report

ample: Demonstrates the color and underline
ttributes by highlighting birthdays of
mployees that fall in the current month.

64



Chapter 4 Report Tutorial

2

Click New.

The New Report dialog box displays. It contains the data sources and
the report styles you can choose.

About data sources
Quick Select is for simply choosing columns and specifying selection
criteria and sorting, which is what you want for this tutorial.

SQL Select is for using other SQL options not available with Quick
Select.

Query is for specifying the name of a query that describes the data source.
You define a query in the Query painter.

External is for specifying data that comes from a source other than a
database.

Stored Procedure is for specifying data using a stored procedure.

About report presentation styles
A report presentation style is a predefined way of presenting
information in a report.
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Create the basic report

66

Click the Quick Select data source and the Tabular presentation
style.

Make sure the Preview when built checkbox is not selected and click
OK.

The Quick Select dialog box displays. In this dialog box you select the
table to use and the columns you want included in the report.

Quik SIeIét;l
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4  Click contact.

The contact table’s columns display. For this report you will select five
columns.
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Create the basic report

68

Click last_name, first_name, and title.
Use the scrollbar to scroll the list of columns.
Click phone and fax.

InfoMaker moves the selected columns to the grid at the bottom. You
can use this grid for reordering columns and for providing sort and
selection criteria. For this report you do not need selection criteria, and
you will specify sorting later.

Last Name First Name
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Click OK.

A design version of your report displays in the Report painter
workspace. It uses the columns and report style you selected.

The text for the column headers comes from the repository. The names
of the columns appear where the data values will be displayed.

The repository

The repository stores information about data such as labels and display
formats. When you create forms and reports, InfoMaker uses repository
information to create the basic form or report.

You put information into the repository using the Database painter. For
example, in the Table tutorial you define the label Job Role: for the title
column. Then when you use the title column in a form or report,
InfoMaker uses the label Job Role:.
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Preview the report

Preview the report

Where you are

Create the basic report

> Preview the report
Save the report
Set up the design environment
Define sorting and grouping
Enhance the report
Print the report

In this section you will preview your report to see what it will look like when
you print it. Usually you preview your report when you make changes that
affect the way it looks.

1 Select Design>Preview from the menu bar.

The report displays. Notice that it includes the header information for
the report and information from the database.

Report - (untitled)

Last Name Job Role Phone Fax

Hildebrand Marketing (510) 5551309 (510) 555-4209
Simmon Sales (713) 555-8360 (713) 555-9265
Critch Product development (508) 555-4823 (508) 555-3025
Lambert Administration (617)555-2246 (617) 555-3692
Bullivan Customer support (508) 555-3925 (508) 555-3931
Paull Finance (617) 555-6332 (617)555-1435
Glassmann Product development (617)555-0273 (617)555-9333
Powell Training (617)555-3528 (617) 555-9563
Fish Marketing (617)555-3528 (617) 5553563
[larke Sales (617) 555-4325 (617) 5557638
elley Documentation (617)555-8474 (617)555-2534
Lyman Customer support (510) 555:5378 {510) 555-3372
Davidson Marketing (510) 5557363 (510) 555-9278
Pettengil Sales (510) 555-3533 (510)555-1146
oore Sales (404) 555-4834 (404) 555-8291
Lencki Customer support (617) 5555348 (617) 5554613
aplan Sales (617) 555-3887 (617)555-2398

InfoMaker retrieves information for all contacts and displays as many
as will fit on the screen.

2 Use the scrollbar on the right side of the window to see more data.
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3 Click the Preview button in the PainterBar.

You return to the Report painter workspace.

7



Save the report

Save the report

72

Where you are

Create the basic report
Preview the report

> Save the report
Set up the design environment
Define sorting and grouping
Enhance the report
Print the report

Now you will save the report and give it a name.

1 Make sure you are back in the workspace (if not, click Preview).
Select File>Save from the menu bar.

The Save Report dialog box displays, with the pointer positioned for
you to type a name for the report.

2 Type contacts_by._jobrole.

3 Click in the Comments box and type This report shows my contacts
grouped by job role.

This report shows my contacts grouped by

4 Press the ENTER key.

InfoMaker saves your report.

About saving
Anytime you have completed a unit of work and are satisfied, you should
save your work. To save, select File>Save from the menu bar.




Chapter 4 Report Tutorial

Set up the design environment

Where you are

Create the basic report
Preview the report
Save the report

> Set up the design environment
Define sorting and grouping
Enhance the report
Print the report

In this section, you set up the design environment to make it easier to work.
You will:

¢ Show the edges of objects
¢ Display the grid and ruler

Object edges show how big the objects are. By displaying object edges, you
can easily check for overlapping and make sure the spacing around objects is
what you want. Displayed edges are a design aid only; they do not appear in
the report.

The InfoMaker grid and ruler help you align objects.

If you completed Chapter 2
The design options you set here may already be set correctly.

1 Select Design>Options from the menu bar.

The Report Options property sheet displays.

73



Set up the design environment

74

Make sure the Show Grid option, Show Ruler option, and the Show
Edges option are selected.

Make sure Snap to Grid is not selected.

Click OK.

eport Optio

The workspace shows a dotted grid and a ruler. Text and columns show




Chapter 4 Report Tutorial

Define sorting and grouping

Where you are

Create the basic report

Preview the report

Save the report

Set up the design environment
> Define sorting and grouping

Enhance the report

Print the report

Now you will specify sorting and grouping. You want the report to group
contacts by title. This means you need to sort by title and then specify grouping
by title.

1 Select Rows>Sort from the menu bar.

The Specify Sort Columns dialog box displays.
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Define sorting and grouping

76

Move the pointer to the word title in the Source Data box and drag it
to the Columns box.

(To drag, press and hold the left mouse button, move the mouse,
then release the mouse button.)

E Specify Sort Columns

Ascending and Descending

Ascending and descending are options for sorting. Since you are
alphabetizing in this tutorial, you want to sort in ascending (from A to
Z) order. Ascending is the default, so you do not have to do anything.

You’ve specified the sorting required to group on title.

Next you will specify sorting by last name and then by first name. This
ensures that your contacts are alphabetized within each group.

Drag /ast_name and first_name to the Columns box.

vS ecify Sort Columns

Click OK.

The sorting definition is complete. You return to the Report painter
workspace.
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Select Rows>Create Group from the menu bar.

The Band Object property sheet displays. You are going to group on
the title column. All contacts with the same title will be grouped
together.

Drag title to the Columns box and click OK.

The grouping definition is completed. You return to the Report painter
workspace.

You have two new bands for the group in the report. You’ll learn about
bands in the next section.
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Define sorting and grouping

7 Select Design>Preview from the menu bar.

You see the report and its data. Notice that the data is sorted. You do
not see the groups yet. In a few minutes, you will make some changes

=

teport - {untitled)

so the groups will appear.

78

8 Click the Preview button.

You return to the Report painter workspace:

Last Name First Name Job Role Phone Fax

Brier Michael Administration (617)555-2338 (617)555-3337
ambert Teny Administration (617) 555-2246 (617) 555-3692
Romeo John Administration (310) 555-4533 (310)555-1233
obb Paul Customer support (404) 5552233 (404) 5558111
ohen Paul Customer support (617)555-8883 (617)555-4433
olfins MaryBeth Customer support (617)555-1133 (617)555-9588
oggin Kevin Customer support (713) 555-3340 {713)555:9211
apne ‘Wiliam Customer support (508) 555-7780 (508) 555-4422
lodson Jack Customer support (508) 555-2398 (508) 555-0022
encki John Customer support (617) 5555348 (617) 5554613
yman Thomas Customer support (510) 5555378 (510) 5553372
asalsky Kurt Customer support (404) 5555111 (404) 555-8347
Reeves Scott Customer support (603) 555-0388 (603) 5555556
Short Russel Customer support (617)555-0933 (617)555-1170
Bullivan Dorothy Customer support (508) 555-3925 (508) 555-9331
ippet Debbie Customer support (708) 555-8227 (704) 5558474
Coleman Documentation (706) 555-2886 (704) 555-4532

5-2594.
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Enhance the report

Where you are

Create the basic report
Preview the report
Save the report
Set up the design environment
Define sorting and grouping

> Enhance the report
Print the report

You can enhance reports in many ways. In this section you will:
Rearrange objects

Add a title and date

Add page numbers

* & o o

Add a count of the total number of contacts
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Enhance the report

Rearrange objects
To rearrange objects, you will:
¢ Put the job role into the group header and change its display font
¢ Move the remaining columns to close the gap left by moving the
column
This is what the workspace will look like when you have finished rearranging

the objects.
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About report bands
The design version of the report that you see in the workspace divides the
report into bands of information.

The header band contains heading information and is located at the top of
each page.

The detail band contains the retrieved data.

The summary band contains summary information that applies to the entire
report and is located at the end of the report.

The footer band contains information to be located at the bottom of every
page, such as a page number.

For groups, the group header band and group trailer band contain
information for the group.

1 Move the pointer to the gray bar entitled 1: Header group title until
you see a double-pointed arrow.

2 Drag the band down about 4 to 6 grid dots.
(To drag, press and hold the left mouse button, move the mouse,
then release the mouse button.)

&5 Report - contacts_by_jobrole

- {fisst_name
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Enhance the report

3 Move the pointer to the title column and drag it into the band for the
group header.
Put it near the bottom of the band as shown.

4 With the title column still selected, click B for bold and / for italic on
the StyleBar.

This makes the job role (title) stand out in the report.
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5 Select Design>Preview from the menu bar.

You see the report and its data.

Last Hame First Name

Adiminsstration
Brier Michael [617) 555-2398 (617) 5553337
Lambert Teny (617) 555-2246 (617) 555-3692
Romeo John (310) 555-4533 (310} 555-1233

Lustamer support
Cobb Paul (404) 555-2239 (404) 5558111
Lohen Paul (617) 555-8883 (617)555-4433
Collins ManBeth (617)555-1193 [617) 555-9586
Goggin Kevin (713) 555-3340 (713) 555-9211
Hayne Willam (508) 555-7780 (508) 555-4422
Hodson Jack (508) 555-2958 (508) 555-0022
Lencki John (617) 555-5348 (617) 555-4613
Lyman Thomas (510) 555:5378 (510) 555-3372
Masalsky Kurt (404) 5555111 (404) 555-8347

i . on FEE EECe

Notice that the value of the title column appears only once for each

group. This is because the title column is now located in the group
header band.

Previewing is helpful for identifying problems. Notice that the header
Job Role is still present even though there is no longer a column in the
detail band. When you return to the workspace you will delete the text.

Click the Preview button to return to the workspace.
Click the text Job Role in the header field.
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Enhance the report

7 Press the DELETE key.

3 Report - contacts_by_jobrole

8 Drag the First Name and Last Name textboxes in the header band to
the right to fill the empty space

5 Report - contacts_by_jobrole

E§ Report - contacts_by_jobrole
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9 Drag the first_name and last_name columns in the detail band to the
right to fill the empty space.

ELE contacts_by_jobrole

B Report - contacts_by_jobrole

You will make one final visual improvement now by left aligning the
text in the column headers.

10 Choose Edit>Select>Select Text from the menu bar.

This selects all the headers. It may be difficult to see that they are
selected because the band is so narrow.
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Enhance the report

11 Click the left justification button on the StyleBar.
If your headers are not already bold, click the Bold button.

All the headers become left justified (and bold).

o

5 Report - contacts_by_jobrole

12 Select Design>Preview from the menu bar.

contacts

First Name
Administration
Brier Michael (617)555-2338 (617) 555-3337
Lambert Teny (617) 555-2246 (617)555-3692
Romeo John (310) 555-4533 (310)555-1233
Lustomer support
Cobb Paul (404) 5552239 (404) 5558111
Cohen Paul (617) 5558883 (617)555-4433
Collins MaryBeth (617)555-1199 (617) 555-9586
Goggin Kevin (713)555-3340 (713)555-9211
Hayne William (508) 555-7780 (508) 555-4422
Hodson Jack (508) 555-2998 (508) 555-0022
Lencki John (617) 5555348 (617) 555-4619
Lyman Thomas (510) 5555378 (510) 555-3372
Kurt (404) 5555111 (404) 555-8347

13 Click the Preview button to return to the workspace.
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Add a title and date

Now you will add a title and date to the header band. They will be at the top of
each page.

1 Move the pointer to the gray bar marked Header and drag it down
about 10 grid dots.

2 Choose Edit>Select>Select Text from the menu bar (or use lasso
selection).

This selects all the headers.

3 Press the DOWN ARROW key to move all the headers down close to
the gray band.

This leaves room for the title.

Repoit - cont
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Enhance the report

Click the Text button in the Objects dropdown toolbar in the
PainterBar (or select Objects>Text from the menu bar).

Move the point of the pointer above the First Name box and down
one grid dot from the top of the page.

Click.

This positions the text box for the title.

Report - contacts_by_jobrole

5 Type My Contacts.
Select 74 from the font size dropdown listbox to make the titie
bigger (enlarge the text box if necessary).

InfoMaker

My Contacts
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Click the Today button in the Objects dropdown toolbar.
Move the point of the pointer to the upper-left corner.
Click.

This places a computed field in the report. The computed field is for
today’s date.

7 Select Design>Preview from the menu bar.

Your report now has a title and today’s date.

L 55 Report - contacts_by_jobiole

My Contacts

Last Name First Name Phone Fax
Administrati

Brier Michael (617)555-2338 (617)555-3337

Lambert Teny (617)555-2246 (617)555-3692

Romeo John (310) 5554533 (310)555-1233
Lustomer support

Cobb Paul (404) 555-2239 (404) 555-8111

Cohen Paul (617) 555-8883 (617) 555-4433

Coliins (617)555-1199 (617) 555-9585

(713) 555-3340 (713)555-9211

8 Click the Preview button to return to the workspace.
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Enhance the report

Add page numbers

Now you will put page numbers in the footer band.

1 Move the pointer to the gray bar marked Footer and drag it down
about 4 grid dots.
If necessary, use the scrollbar to make room at the bottom of the
design workspace.

This makes space for the page number, which will be another computed
field.

Report - contacts
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Click the Page button in the Objects dropdown toolbar.

In the footer band, move the point of the pointer to the center and
down 2 grid dots.

Click.

Select a different font size (10) from the style bar.

This places a computed field for page numbers.

ort ]

3 Select Design>Preview from the menu bar.
Click the scrolibar until you move to the bottom of the page.

You now have a page number on your report.

Towley Charles b1/ 555-134 b1 7] 555-98

Schott Amy (713)555-891 (713) 555-4565
Markeling

Davidson Joann (510) 555-7363 (510) 555-9278

Fish Jeffrey (617) 555-3528 (617)555-9563

Galvin Liz (617) 5558312 (617) 5559870

Hildebrand Jane (510) 555-1308 (510) 555-4203

Shishoy liina (404) 5551233 (404) 555-6837

‘Weaver Joe (713) 555-1956 (713) 555-4455
Oeher

Rayner Doug (713)555-8444 (713) 555-9934

Page 1 of 2

4 Click the Preview button to return to the workspace.
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Add a count of the total number of contacts

Now you will add a count of the total number of contacts you have to the end
of the report. You will put the information in the Summary band, which means
it will print at the end of the report.

Like the date and page number, the count will be a computed field. Only this
time, you will create it yourself using the Compute button.

1 Move the pointer to the gray strip marked Summary for the
summary band and drag it down about 6 grid dots.

This makes space for the total number of contacts, which will be a
computed field.

Click the Compute button in the Objects dropdown toolbar.

In the summary band, move the point of the pointer to the center
and down 4 grid dots.

Click.

This sets the position for a computed field that you will use for the total
number of contacts. The Computed Object property sheet displays.
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3 In the Name box, type total_contacts.

j Computed Object

4 Click the More button.
The Modify Expression dialog box displays.

5 Inthe Functions box, click count(#x for all).

Your dialog box should look like this. The placeholder for what to
count is highlighted.

HDEIl[} Expres‘sion

avg( Hx for all)

bitmap (5]

ceiling( % ]
case[xwhenathenby
char(®) .

cos{x]
count{ #x for all )
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Enhance the report

6 In the Columns box, click /ast_name.

This selects the last_name column to apply the count function to. You
are going to count all the last names to find out how many contacts you
have in the report.

7  Click Verify.

You should get the message box stating that your expression is valid.

8 Click OKto close the message box.
Click OK to complete the definition of the expression for the
computed field.
Click OK to accept the name and expression and close the
property sheet.

You return to the workspace. The computed field is in place.
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10

Click the Text button in the Objects dropdown toolbar.

Position the pointer to the right of the computed field and click.
Type contacts in all.

Drag the text box to line it up with the computed field.

lcount{  [contacts in

e
[Page ‘s page

Select the computed field and the text using lasso selection.
On the StyleBar, select 70 for a font size and click / for italic and B
for bold.

How to use lasso selection

Position the pointer, press and hold the left mouse button, and drag the
lasso around everything you want to select. Then release the mouse
button.

95



Enhance the report

96

11 Select Design>Preview from the menu bar.

Press the PAGE DOWN key and use the scrollbar until you see the
end of your report.

The summary band of your report now shows the total number of
contacts in the report. The number you see may not be 61. The number
depends on the contacts currently in your database.

E5 Report - contacts_by_jobrole

Trainng

12 Click the Preview button to return to the workspace.

Moore Dawn
Page Lynn
Pettengil Mark.
Philley Mary
Purcell Beth
Quinn Peter
Simmon Larmy
Trayers Ken
‘White Pauline
Elkins John
Long Peter
Miller Henry
Powell Gene

contacts in all

(404) 555-4834
(617)555:8830
(5610) 555-3533
(713)555-3338
(617)555-2343
(617) 555-2222
(713) 555-8960
(617)555-2384
(713) 5553345

(603) 555-1200
(617) 555-4519
(617)555-3356
(617)555-3528

(404) 555-8291
(617)555-4544
(510)555-1146
(713) 555-9066
(617)555-1765
(617) 5559337
(713) 555-9265
(617) 5554127
(713)555-9222

(603) 555-0078
(617)555-4333
(617) 5551332
(6175559563
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Print the report

Where you are

Create the basic report
Preview the report
Save the report
Set up the design environment
Define sorting and grouping
Enhance the report

> Print the report

1  Select Design>Preview from the menu bar.

Your report displays.

2 Select File>Print from the menu bar.
The Windows Print dialog box displays.

3 Click OK.
4  After printing, click the Preview button to return to the workspace.
5 Select File>Close from the menu bar.

If you are prompted to save changes, click Yes.

This closes the Report painter.
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Print the report
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CHAPTER 5

Table Tutorial

This tutoriai requires the Database painter
The Database painter component of InfoMaker is optional; you must
have installed it to do this tutorial.

Tables are the way relational databases organize information. To take full
advantage of InfoMaker’s ability to create forms and reports, you should
learn how to create and work with database tables.

InfoMaker is installed with a SQL Anywhere database. You can create
and work with tables in the SQL Anywhere database and in any other
database you have access to.

After you create a table, you can display its columns on a form and use the
form to add information into the database. For a final printed copy of the
data in your tables, you can create and print reports.

In this tutorial you will:

¢ Create a database table

¢ Define extended attribute information
¢ Add data to the table

When you are finished, you can create forms to view and update
information, and you can create and print reports using information in the
table.

How long will this tutorial take?
About 45 minutes.
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Create the database table

Create the database table

100

Where you are

> Create the database table
Define extended attribute information
Add data to the table

To create the database table, you will:
¢ Define the columns in the table
Define a primary key

Enter comments to document the table

* & o

Save the table
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Define the columns in the table

1 Click the Database painter button in the PowerBar.

ii InfoMaker

The Select Tables dialog box displays. It lists the tables in the current
database and has a New button for creating new tables.

2 Click New.

You go to the Table painter. In the top part of the Table painter
workspace, you define the columns in the table. In the bottom part of
the workspace, you define extended attributes for each column. The
cursor is in the Column Name box for the first column.

Create Table - (Untitled)
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Create the database table

102

Type id and press TAB.

The cursor moves to the Type box. The default data type (varchar) is
highlighted. The data type for the id column needs to be integer.

About default data types
Varchar is the default data type for the first column. The default data
type for subsequent columns is the type of the previous column.

Click the arrow to the right of the word varchar and select integer
from the dropdown listbox of available data types.

This changes the data type.

Press TAB three times.

This moves you past the setting of No for the column labeled Null. No
means you do not want to allow the column you are defining to be
empty (to have a null value). Since you always want a value for id, you
will leave the value No. You also move past the column labeled
Default. You are not going to specify a default.

Create Table - (Untitled)

Type last_name and press TAB.

The cursor moves to the Type column. The most recently used data
type (integer) is highlighted. Last_name should be type char, so you
will change it.

Type c and press TAB.

Typing c is a shortcut for choosing char quickly. The cursor moves to
the Width column.

Type 15.

This allows 15 characters for the last name instead of 10.
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Press TAB three times.

This moves you past the setting of No for the column labeled Null to
the Name box for the next column. No is what you want (name cannot
be empty). Again, you move past the column labeled Default.

Finish entering information about the table columns.

The following table shows all the values needed to define the columns
in the contact table. You have already entered values for the first two
columns (id and last_name).

Name Type Width Dec Nuli Default
id integer No (None)
last_name char 15 No (None)
first_name char 15 No (None)
title char 2 No (None)
street char 30 No (None)
city char 20 No (None)
state char 2 No (None)
zip char 5 No (None)
phone char 10 Yes (None)
fax char 10 Yes (None)
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Create the database table

104

When you are done, the workspace should look like this.
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Define a primary key
A primary key uniquely identifies each row. In your contact table, id is the

unique identifier of each row of data.

1 Select Edit>Table Properties from the menu bar.

The Table Properties property sheet displays.
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Create the database table

2 Click the Primary Key tab.

On this page, you can pick one or more columns as the primary key.

able Properties

106



Chapter 5 Table Tutorial

3

Click id in the list of columns.

Id displays in the box for Key Columns.

This defines id as the primary key for your table.

Next you will use another page on the property sheet to define a
comment for the table.
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Create the database table

Enter comments to document the table

Although not required, comments can be helpful in identifying tables.
1 Click the General tab.

2 Clickin the Table comment box and type This is the sample table for
the tutorial created by [your name].
Click OK.

his is the sample table for the tutorial created by Jane
terling.

This associates the comments with the table you are creating. The
property sheet closes and you return to the workspace.
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Save the table

You have now entered all of the information needed. Now you will finish
creating the table.

1 Select File>Save from the menu bar.
The Create New Table dialog box displays.

You wili ieave the owner as dba (database administrator) and enter a
name for the table.

2 Type contact1 in the Table Name box.
Click OK.

InfoMaker passes the SQL needed to create the table to the SQL
Anywhere DBMS, which creates the table. InfoMaker changes the title
bar in the workspace to display the owner of the table (dba) and the
name of the table. The words Read-Only also display in the title bar.
This means you cannot change the table definition at this point.
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Create the database table

3 Select File>Close from the menu bar.

InfoMaker closes the Table painter and displays a representation of the
table in the Database painter workspace.

The list of columns displays. The scrollbar on the right side means that
there are more columns than can be displayed at once. To see the other
columns, click the down arrow at the bottom of the scrollbar.

The symbol on the right indicates that the table has a primary key. You
can double-click the symbol to see the definition of the primary key.
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Define extended attribute information

Where you are

Create the database table
> Define extended attribute information
Add data to the table

Now you will extend the basic definitions of the columns in the table.

The following table summarizes how you will extend the column definitions of
the contactl table columns.

Column name What you will do to extend its definition

id Nothing

last_name

first_name

title Define a DropDownListBox edit style of job roles, change
the column header and label to Job Role, and enlarge the
display width of the column to 1.5 inches

street Nothing

city

state Assign the DropDownDataWindow edit style for state to
the state column
Set the default value of state to MA

zip Nothing

phone Define an Edit Mask edit style for a phone number and

fax apply it to phone and fax

About extended attribute information

InfoMaker stores extended attribute information in the repository and uses
it to display and validate data in forms and reports. In the Report painter or
Form painter, you can override whatever you specified in the Database
painter, which is where you are now.
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Define extended attribute information

Define a DropDownListBox edit style for the title column

112

Now you will define a DropDownListBox edit style that has the valid job roles
for the title column. When you are finished, this is what it will look like in a
form.

Marketing
Administration
Customer support
Documentation
Finance

Human resources
b arketing
Other
Product development

1 Position the pointer on title.
Click the right mouse button.

A popup menu for the title column displays. You can use this menu to
extend the definition of the column.
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2  Select Properties from the popup menu.
The property sheet for the title column displays.

1 ulie”

3  Click the Edit Style tab.

To supply an edit style for the title column, you can pick from the list
of available edit styles or create a new style. You are going to create a
new one.

Department List

{EF] Dollars with cents
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Define extended attribute information

4 Click the New button.
The Edit Style dialog box displays.

| Edit Style

5 Enter the name JobRoles]1.
Select DropDownListBox in the Style box next to Name.
Click Sorted to alphabetize your entries.
Click Vert Scroll Bar to display a vertical scrollbar on your list.

Edit Style

DropDownlListBox
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Enter the Display Values and Data Values shown in the table below.
Be sure to use lowercase for the data values.

To enter each pair of values, type the values and click the Add
button.

For the last pair of values, do not click Add.

Display Value Data Value
Sales sa
Customer support cs
Product development pd
Administration ad
Training tr
Documentation do
Marketing ma
Human resources hr
Finance fi
Other ot
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About display values and data values

Display values show in forms and reports. Data values are stored in the
database. Display values should be meaningful—for example, Human
Resources. In contrast, data values are often codes that are small—for
example, hr. Small codes conserve space in the database.

7 Click OK to accept the definition of the DropDownListBox edit style
named JobRoles1.

You return to the Edit Style page of the property sheet for the title
column. JobRoles! is now listed as one of the available edit styles.

Ell Customers

Department List
Dollars with cents
Employee Status

8 Be sure JobRoles1 is highlighted.
Click OK in the property sheet to apply the edit style JobRoles1 to
the title column.
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Change the column header, label, and display width of title

Now you will change the label and header text for the title column. The text
you supply will appear on forms and reports you create.

Title is the field (column) name, but the text you want to display is Job role.
Also, you will change the display width to 1.5 inches. The internally stored
data value is only two characters, but the values you intend to display are
longer.

1 Position the pointer on the title column
Press the right mouse button.
Select Definition from the popup menu.

The Table painter workspace displays.

The arrow points to title and it’s highlighted, which means it’s the
current column. Information about the title column displays in the
bottom half of the workspace.

All the extended attribute information for a column displays at the
bottom of the workspace. Notice that the edit style JobRoles1 displays
as currently assigned to the title column.
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2 Type Job Role in the Header box.
Type Job Role: in the Label box.
Type 1.5 in the Width box.

3 Select File>Save from the menu bar.

InfoMaker adds the extended attribute information to the repository.
4 Select File>Close from the menu bar.

InfoMaker closes the Table painter and returns to the Database painter
workspace.
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Assign a DropDownDataWindow edit style and initial value to state

For the state column, you will assign an edit style that includes all the state
names (as well as the provinces of Canada). Then when you enter information
into this field, you pick from a list of states. You will also set the initial value
to MA since a large number of your contacts are in Massachusetts.

1 Position the pointer on state.
Click the right mouse button.
Select Propeities from the popup menu.

The property sheet for the state column displays.
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Define extended attribute information

2 Click the Edit Style tab.

The Edit Style page for the column displays. It includes a list of
available edit styles and a New button for creating new edit styles.

BenefitsCheckBox
|ET Color List

{@® Employee Status
EEl employees
EEll Financial Codes

3 Click the New button.
The Edit Style dialog box displays.
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Type StateCode1 in the Name box.
Select DropDownDW from the Style dropdown listbox.
Select d_dddw_states from the DataWindow dropdown listbox.

The StateCodel edit style references a report (DataWindow) named
d_dddw_states. The report gets its values from the State table.

{_dddw_products
|_dddw_sales_orders
|_dddw_sales_reps

About DropDownDataWindow edit styles
A DropDownDataWindow edit style gets its values from a report that it
references. The report gets its values from the database.

This is what the d_dddw_states report looks like.

5 Report - d_dddw_states
D Name Country,
AB_ |Alberta CAN
AK Alaska USA
AL lAlabama USA
AR jArkansas USA
AZ iArizona USA
BC |British Columbia CAN
CA ICalifornia USA
CO _|Colorado USA
Connecticut
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Define extended attribute information

122

Select state_id from the listbox for Display Column and for Data
Column.

Select V Scroll Bar.

Type 550 for the Width of DropDown.

Click OK.

d_dddw_states

You return to the state column’s property sheet. StateCodel, the style
you just created, displays in the list and is highlighted.

E1 Prod_desc
Products
ET region

Sales Orders

StateCode

In a few minutes you will click OK. This will assign the StateCodel
edit style, which includes 63 entries—states, territories, and
possessions of the United States and provinces of Canada. The values
that this edit style displays and the values that it stores are state postal
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abbreviations (such as MA for the state of Massachusetts).

6 Click the Validation tab.

The Validation page lets you create and assign a validation rule to a
column and enter an initial value for the column.

You are not going to assign a validation rule. You have handled
validation by forcing the user to select from exactly 63 valid values.

However you are going to set an initial value.

About column validation rules

You can use column validation rules to express requirements for entries
in a column. For example, you could define a rule for a salary column
that requires salaries to be greater than $15,000 and less than $100,000.

When you assign a column validation rule to a column, no one can enter
a value that breaks the rule.
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7 Type MA in the Initial Value box and click OK.

This assigns an initial vaiue of MA to the state field and closes the
property sheet.

must_be_number
valid_status
Y_or N
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Define an Edit Mask edit style for phone and fax

Now you will define an Edit Mask edit style to display phone numbers for both
viewing and editing.

1 Position the pointer on phone (scroll the list of columns if
necessary).
Click the right mouse button.
Select Properties from the popup menu.
Click the Edit Style tab on the property sheet.
Click the New button on the Edit Style page.

The Edit Style dialog box displays.
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126

Type TelephoneNumber1 in the Name box.
Select EditMask in the Style dropdown listbox.
Delete the xxx’s and type (###) ###-#### in the Mask box.

This specifies the edit mask. Now you can test it to make sure it is what
you want.
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3 Press TAB.
Type 6175552145 in the Test box.

The pound signs (#) in the Mask box are placeholders for numbers.
Only numbers 0 through 9 can be entered in each of these positions.
Parentheses, the hyphen, and the space are where you want them to
display. When you type a telephone number in the Test box, you can
see the effects of the edit mask.

4 Click OK to accept the definition of the Edit Mask edit style named

TelephoneNumber1.
This takes you to the Edit Style dialog box.
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5 Scroll the list and select the TelephoneNumber1 edit style.

olumn contactl.phone

statusedit

6 Click OKto apply the TelephoneNumber1 edit style to the phone
column.

You return to the Database painter workspace. Now you will use the
same edit style with the fax column. Once you have created an edit
style it is available for any column.
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7 Position the pointer on fax (scroll the list of columns if necessary).
Click the right mouse button.
Select Properties from the popup menu.
Click the Edit Style tab in the property sheet.
Click TelephoneNumber1 in the list of styles (scroll the list).
Click OK to apply the TelephoneNumber1 edit style to the fax
column.

StatusDDLB
statusedit

Now you are finished extending the definitions of your columns. Next you will
add data to the table.
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Add data to the table

Add data to the table

Where you are

Chapter5 Table Tutorial

Create the database table

Define extended attribute information
> Add data to the table

To add data to your table, you will import a text file of tab-separated values.
Importing the file quickly adds 60 rows of data.

Typically you create a form to add data to the database. In the form tutorial you
saw how to add data using a form.

1 Select Object>Edit Data>Grid from the menu bar.

The Data Manipulation painter opens. This painter is a workspace that
lets you view, add, modify, and delete data.

2 Select Rows>Import from the menu bar.

The Select Import File dialog box displays. You may need to change to
the Tutorial folder, which contains the file you will use.
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3 If necessary, change to the Tutorial folder.
Double-click the contact.txt file.

InfoMaker imports the data into the Data Manipulation painter (the
data is not yet in the database).

B Data Manipulation for

Click the Update Database (Update) button.

This adds the 60 rows of data to the database. To be sure that the data is
in the database, you will retrieve it from the database.

Click the Retrieve button.

InfoMaker retrieves all the contact data from the database and displays
the data that fits in the Data Manipulation painter workspace.

6 Select File>Close from the menu bar.

This closes the Data Manipulation painter workspace and returns you to
the Database painter.

7 Select File>Close from the menu bar again.
This closes the Database painter.

You have created a new database table, complete with repository information
and data.
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A query is a SQL SELECT statement created with the Query painter and
saved with a name so that it can be used repeatedly to define data
requirements. A SQL SELECT statement is the way you tell the DBMS
exactly which rows and columns to retrieve.

Queries save time because you can specify all your data retrieval needs
once in the query. For example, you can specify the columns and rows to
select, as well as the sorting requirements. Then you specify the query as
the data source whenever you create forms and reports that use the data
the query retrieves.

How long will this tutorial take?
About 15 minutes.
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About the query

About the query

The query you will create retrieves financial data. When you are done, the
query will return data from the database similar to this.

* Query - (q_expenses)

The financial data is stored in two tables: the fin_data and fin_code tables.

The following illustration shows the two tables with some data. The code value
in the fin_data table gets its meaning from the fin_code table.

E BEE] Manlpuialmn for fin_data % bala Manipulation for fin_code

For example, the r1 circled in the fin_data table means the row reports a
revenue amount for fees.
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Chapter 6 Query Tutorial

Select columns

Where you are

> Select columns
Save the query
Specify row selection criteria

Create a report using the query

1 Click the Query painter button in the PowerBar.

InfDMakér

The Select Query dialog box displays. It lists queries in the current
library and has a New button for creating new queries.

ample: Query that retrieves data from the -
ustomer, Sales Order, and Product tables.
ncludes the Sales Order Items table so the
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Select columns

2 Click New.

The Select Tables dialog box displays. In this dialog box you can select
one or more tables to use.

You are going to use two of the tables.

3 Click the tables named fin_code and fin_data.

xamples_categories_list

xamples_groups
’ F
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Click Open.

The fin_code and fin_data tables display. The tables are joined on the
code column. Both tables have a code column.

L Query - (Untitled).

The fin_data table has a code value in each row to indicate what the
row of data applies to (for example, r1 means revenue from fees).

The fin_code table stores information about codes, including the actual
values (such as rl1 and e4), the type of each code (revenue or expense),
and a description of each code.

Next you will select columns from the tables.

Click year in the fin_data table.

Click quarter in the fin_data table:
Click amount in the fin_data table.
Click type in the fin_code table.

Click description in the fin_code table.

When you click each column, it is highlighted in the table and added to
the selection list above the tables.

Query - (Untitled)

quarter | |amount ‘ eslip!in

137



Select columns

6 Click the Preview button.

You can see the results of your query. InfoMaker uses your query as it
is currently defined to access the database and retrieve data.

7 Use the scrolibar to view the data.

Each row has either the word expense or the word revenue in the Type
column. First you will save the query and then you will use the value in
the Type column to select rows for the query.

Click the Preview button.

You return to the workspace.
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Save the query

Where you are

Select columns

> Save the query
Specify row selection criteria
Specify sorting for the rows
Create a report using the query

Now you will save the query and give it a name.

1 Make sure you are back in the workspace.
Select File>Save from the menu bar.

The Save Query dialog box displays with the pointer positioned for you
to type a name for the query.

2 Type q_expenses.

hat_your_customers_are_ordering
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Save the query

3  Click in the Comments box and type This query retrieves financial
data from the fin_data and fin_code tables. The query selects expense
rows and sorts rows by year, description, and quarter.

at t_your_customers_are_ordering

fin_data and fin_code tables. The query
selects expense rows and soits rows by year,
description, and quarter.

4 Press ENTER.

InfoMaker saves your query.

About saving
Anytime you have completed a unit of work and are satisfied, you should
save your work. To save, select File>Save from the menu bar.

140



Chapter 6 Query Tutorial

Specify row selection criteria

Where you are

Select columns
Save the query

> Specify row selection criteria
Specify sorting for the rows
Create a report using the query

Now you will select the rows to include in the query. To do this you specify
selection criteria.

The query you are creating is for expenses. So the rows you need are those
whose type is expense. You do not need the rows whose type is revenue.

1 Click the Where tab in the SQL toolbox if it’s not in front.

The Where tab comes to the front of the SQL toolbox. In the Where
tab, you specify selection criteria for retrieving rows.
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Specify row selection criteria

142

2

Click the first space under column and then click the arrow to
display a listbox of columns.
Click the column named "fin_code"."type" in the list of columns.

The equal sign (=) displays by default in the Operator box. This is what
you want.

Move the pointer over the Value box.
Press the right mouse button to display the popup menu.
Select Value.

When you select Value, InfoMaker lists the values in the
"fin_code"."type" column, which are expense and revenue.
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4 Select expense and click the Paste button.

The selection criteria are complete. Notice that 'expense' is surrounded
with single quotes. These are required. If you type the value here rather
than choosing it, you need to type the single quotes.

Notice that the Logical box displays at the end of the line. This box is
for choosing a logical connector such as AND so that you can specify
more than one selection requirement. You do not need to use this box
for this query.

Click the Preview button.
Use the scrollbar to view the data.

Now all rows have expense in the type column. Rows with revenue in
the type column are not retrieved.

Query - [q_expen:

6 Click the Preview button.

You return to the workspace.
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Specify sorting for the rows

Specify sorting

for the rows

>

Where you are

Select columns

Save the query

Specify row selection criteria
Specify sorting for the rows
Create a report using the query

Now you will specify sorting for the rows. When you specify sorting, you also
enable grouping. Before you can define a group, the rows have to be sorted so
that the data can be grouped.

144

Click the Sort tab in the SQL toolbox.

The Sort tab comes to the front. In the Sort tab, you specify one or
more columns to use for sorting the rows.

_data"."quarter”
1_data""amount”

R

Scroll the list as needed to drag and drop column names.

Drag and drop “fin_data"."year" from the left box to the right box.
Drag and drop "fin_code". "description” from the left box to the right
box.

Drag and drop "fin_data"."quarter” from the left box to the right box.

In all cases Ascending is what you want. Ascending means years and
quarters are ordered by increasing values and descriptions will be
alphabetized from A to Z.

Ascending: |

in_data"."quarter" in_code"."description"
in_data"."amount"" in_data"."quarter” Ascending:
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Click the Preview button.
Use the scrollbar to view the data.

First the rows are sorted by year. All the 1995 information is first. Then
they are sorted by description so that expenses of the same category are
together. Finally the rows are sorted by quarter so that the data is
always time-sequenced.

.. Query - (q_expe

4 Click the Preview button.

You return to the workspace.
5 Select File>Close from the menu bar.

If prompted to save changes, click Yes.

The Query painter closes.
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Create a report using the query

Create a report using the query

Where you are

Select columns
Save the query
Specify row selection criteria
Specify sorting for the rows
> Create a report using the query

Now you will use the query to create a new report.

Click the Report painter button in the PowerBar.

The Select Report dialog box displays. It lists the reports you create
and has a New button for creating new reports.

2 Click New.

The New Report dialog box displays. It contains the data sources and
the report presentation styles you can choose.

You are going to use the query you just created as the data source.
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Chapter 6 Query Tutorial

3 Click Query and Tabular and click OK.

—

Mew Report

The Select Query dialog box displays. In this dialog box you select the
query to use.

what_your_customers_are_ordering

s query retrieves fina
in_data and fin_code tables. The query
elects e; d sort b

year

147



Create a report using the query

4 Click g_expenses and click OK.

A design version of your report displays in the Report painter
workspace.

5 Report - (untitled)

5 Select Design>Preview from the menu bar.

The report displays. InfoMaker uses the query you created to retrieve
data from the database. Because the query includes selection criteria
and sorting requirements, the database returns only the data you
selected, in the sort order you specified.

EEN

935 1
935 Q2
935 @3
935 Q4
935 Q1
935 Q2
9% @3
935 Q4
9% a1
935 Q2
9%5 Q3
9% Q4
935 Q1
9% Q2
935 @3
935 Q4
a1
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Year QuarterAmount in thousands

381
402
412
467
101
93
128
145
623
784
856
1043
1437
2033
2184
2145
403

Type
expense
expense
expense
expense
expense
expense
expense
expense
expense
expense
expense
expense
expense
expense
expense
expense
expense

Administration
Administration
Administration
Administration
Fees

Fees

Fees

Fees

R&D

R&D

R&D

R&D

Sales & Marketing
Sales & Marketing
Sales & Marketing
Sales & Marketing
Services

Description
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Click the Preview button.
You return to the Report painter workspace.

At this point you could continue designing and improving your report.
But for this tutorial, you will leave the Report painter now. You will
not save the report.

Select File>Close from the menu bar.

This Message Box displays to see if you want to save your report.

Click No.
The Report painter closes.
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Create a report using the query

150



CHAPTER 7

Graph Tutorial

Graphs present data in a visual way so that you can more easily interpret
the data. You can use graphs to supplement the numbers in a report or you
can replace numbers with a graph. InfoMaker provides a variety of graph
styles and options.

The graph you create in this tutorial uses financial data (the same data as
the Query tutorial). You will start with a report that’s already created and
add a graph to the report. When you have finished, the report and the graph
will look like this.

E 55 Report - expenses_grapl

3/19/98

Expenses for 1995 Page 10f3
Amount
in thousands Expense Breakdown
Administration
Q1 381 1371% 10.84%
Q2 402
Q3 412 BB Administration
4 467 BB Fees
N RrR&D
1662 3 sales &Marketing
Fees B3 services
a1 101
Q2 93
Q3 129
Q4 145
468

How long will this tutorial take?
About 30 minutes.
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Open the report to contain the graph

Open the report to contain the graph

Where you are

> Open the report to contain the graph
Create the basic graph
Preview the graph
Save the graph (report)
Enhance the graph
Print the graph (report)

First you will open a report that has been created for you. This report will
provide the data for your graph.

1 Click the Report painter button in the PowerBar.

In’f;yMakel e

The Select Report dialog box displays. It lists reports in the current
library (TUTOR_IM). You will be using the report named expenses.

Select Heﬁml

p_telephone_:
mp_total_compensation
3 d_sal

utorial: Used for tutorial. Expenses for years
21994
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Chapter 7 Graph Tutorial

2

Click expenses (scroll the list if necessary).
Click the Design button.

The design version of the report displays in the Report painter
workspace.

Select Design>Preview from the menu bar.

The report displays. InfoMaker retrieves information from the database
and displays as much as will fit on the screen.

| 5 Hepor - expense

Administration

Fees

a1
Q2
Q3

3/19/98
Expenses for 1995 Page 1 of 3
Amount
in thousands
381
402
412

467
1662

101

93
129
145

468
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Open the report to contain the graph

154

Use the PAGE UP and PAGE DOWN keys on the keyboard and the
scrollbar on the right edge of the report to see more data.

The entire report consists of three pages: one for 1995, one for 1996,
and one for 1997.

Click the Preview button.

You return to the Report painter workspace.
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Create the basic graph

Where you are

Open the report to contain the graph
> Create the basic graph

Preview the graph

Save the graph (report)

Enhance the graph

Print the graph (report)

The report you are working with has three pages, one for each of three years.
The graph you will create will be on all three pages. It will look the same from
page to page, but the data will be for the correct year for each page.

This is what a graph for 1995 looks like. It shows the year’s expenses in five

categories.
S Report - expenses_gioph
3/19/98
Expenses for 1995 Page 1 of 3
Amount
in thousands {None)
Administration 8000
o1 381
Q2 402
a3 M2 o0oe
Q4 467 ~
1662 § 0
Fees 2000
Q1 101
Q2 93
@3 129 O Raminisratio F R&D Sales &Mark Servi
Imini: 0 ees les ervices
Q4 145 (None)
468
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Create the basic graph

1 Select Objects>Graph from the menu bar.
Click in the middle of the report workspace.
The Graph Object property sheet displays. The Data page is on top.

| Graph Object
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Chapter 7 Graph Tutorial

2 Click the down arrow on the Rows box.

The dropdown listbox shows choices for rows.

tNong)

All means to include all rows in the graph. You want to have the
appropriate graph for each of three years, so you do not want all rows
included in the graph at the same time.

Group 1 means to include the rows for the current Group 1. Group 1 for
this report is grouping by year. So Group 1 is what you want. When
you specify Group 1, you ensure that the graph includes only rows

from the current year.

157



Create the basic graph

158

Select Group 1.

Next you will fill in the Category and Value boxes. The graph will
show expenses for the year by type of expense. (For this graph you do
not need to fill in the Series box.)

The description column provides the categories (Administration, Fees,
R&D, Sales & Marketing, Services).

The sum of the amounts for the four quarters for each category

provides the values.

A EH Report - expenses

Administration

Fees

a1
Q2
Q3
Q4

Q1
Q2
Q3
Q4

Expenses for 1995

Amount
in thousands

381
402
412
467

1662

101

93
129
145

3/19/98
Page 10of 3




Chapter 7 Graph Tutorial

Click the down arrow next to the Category box.

A dropdown listbox displays the columns you can choose to supply the
categories to use in the graph. (You can think of categories as X
values.)

Select description.

This specifies that the values in the description column will be the
categories.
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Create the basic graph

160

Click the down arrow next to the Value box.

A dropdown listbox displays all the choices for the column to supply
the values to use in the graph. Notice that the choices include
expressions such as counts and sums.
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Select sum(amount for graph).

This specifies that the sum of the amount column will be the value. A
separate value is calculated for each category within each year.

Al aricrn

tNong)

Click OK.

The Graph Object property sheet closes and the graph displays in the
report. What you see is a representation of the graph. To see what it
will look like in the report you need to preview it.

161



Preview the graph

Preview the graph

Where you are

Chapter 7 Graph Tutorial
Open the report to contain the graph
Create the basic graph
> Preview the graph
Save the graph (report)
Enhance the graph
Print the graph (report)

1 Select Design>Preview from the menu bar.

The report displays. InfoMaker retrieves information from the database
and displays the data both in the report and in the graph. The graph is
small right now. In a few minutes, you will resize the graph.

. & Report - expenses

3/19/98
Expenses for 1995 Page 1 0f 3
Amount
in thousands
Administration
e} 381
Q2 402 -
a3 412
04 467
1662 “
Fees =
Q1 101
Q2 93
Q3 129
Q4 145
468

2 Click the Preview button.

You return to the Report painter workspace.
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Save the graph (report)

Where you are

Open the report to contain the graph
Create the basic graph
Preview the graph
> Save the graph (report)
Enhance the graph
Print the graph (report)

Now you will save the graph. The graph is part of the report, so to save the
graph you save the report that contains it. To leave the original report
unchanged, you will use the Save As command. Save As saves a new report
with the name you supply.

1 Make sure you are back in the workspace.

Report - expenses
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Save the graph (report)

2 Select File>Save As from the menu bar.

The Save Report dialog box displays with the name of the report you
opened earlier highlighted.

3 Type expenses_graph.

4 Click in the Comments box and type This report summarizes expense
data for 1995, 1996, 1997. It includes graphs as well as numeric data.

ave Report

This report summarizes expense data for
1995, 1996, 1997. Itincludes graphs as well
as numeric data.

5 Press ENTER.

InfoMaker saves your report, including the graph.

About saving
Anytime you have completed a unit of work and are satisfied, you should
save your work. To save, select File>Save from the menu bar.
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Enhance the graph

Where you are

Open the report to contain the graph
Create the basic graph
Preview the graph
Save the graph (report)
> Enhance the graph
Print the graph (report)

To enhance the graph you will:

¢ Resize and reposition the graph
¢ Add atitle

¢ Change graph types
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Enhance the graph

Resize and reposition the graph

166

Usually you work in design mode when enhancing a report or graph. But to
resize and reposition a graph, you may find it easier to work on it while
previewing. You can get a much better idea of what the page will look like. The
sizing and positioning changes you make are retained when you return to the

workspace.

1 Select Design>Preview from the menu bar.

| 5 Report - expenses_graph

Administration
[e}]
Q2
Q3
Q4

Fees
Q1
Q2
Q3
Q4

3/19/98
Expenses for 1995 Page 1 of 3

Amount
in thousands

381
402 =

412 -
467 o
1662

101

93
129
145

468
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Resize and reposition the graph so that it looks like the one shown
below.

To make it bigger, put the pointer near a corner or a side until the
pointer changes shape. Then press the left mouse button and drag the
corner or the side. To move it, put the pointer in the middle of the
graph. Then press the left mouse button and drag the graph.

3/19/98
Expenses for 1995 Page 10f3
Amount
in thousands {None)
Administration 8000
Q1 381
@2 402 o000
Q3 412
Q4 467 .
1662 § e
Fees o
at 101 000
Q2 93
a3 129 0 Administratio Fees R&D Sales &Mark Services
i
Q4 145 (None)
468

Use the PAGE DOWN key on the keyboard to display the graphs for
1996 and 1997.

Click the Preview button.

You return to the Report painter workspace.
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Enhance the graph

Add a title

1 Move the pointer to the middle of the graph and click.

This selects the graph. The current title, (None), displays in the textbox
just above the upper-left corner of the workspace.

poit - expenses_graph
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Type Expense Breakdown.

The title displays in the graph and in the textbox.

s InfoMaker
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Enhance the graph

Change the graph type

170

You can use many different types of graphs to present the same data.
Sometimes it’s useful to try different types until you find the one that works
best for the data you are presenting.

Now you will try several graph types with the expense data.

1  If you need to, use the scrollbar to display the entire graph in the
workspace.

2 Move the pointer to the middle of the graph.
Click the right mouse button.

Expense Breakdown
250-‘

200

(None)




Chapter 7 Graph Tutorial

Select Properties from the popup menu.

The Graph Object property sheet displays, with the Graph page on top.
On this page you can choose a graph type. The current graph type is
Column.

[ Graph Object
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Enhance the graph

4 Click the Bar graph type.
Click OK.

I(;[.).h biue;:‘l

InfoMaker redisplays the design version of the graph using the Bar

style.
Expense Breakdown

E.
D

o

5c

=2
B
A

0 50 100 150 200 250
(None)
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Select Design>Preview from the menu bar.

The graph looks like this with real data.

Expense Breakdown

Services

Sales & Marketing.

(None)

Administration

0 2000 4000 6000 3000
(None)
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Enhance the graph

6 Click the Preview button to return to the workspace.
Move the pointer to the middie of the graph.
Click the right mouse button to display the popup menu.
Select Properties.
Scroll the graph types and click the Solid Bar graph type.
Click OK.

xpense Breakdown

InfoMaker redisplays the design version of the graph using the Solid
Bar style.

Expense Breakdown

(None)
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Select Design>Preview from the menu bar.

The graph looks like this.

Expense Breakdown

Services

Sales & Marketing

R&D

(None)

Fees

Administration

2000 4000 6000 2000

(None)

0
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Enhance the graph

Click the Preview button to return to the workspace.
Display the graph’s popup menu.

Select Properties.

Scroll the graph types and click the Pie graph type.
Click OK.

InfoMaker redisplays the design version of the graph using the Pie style.

Expense Breakdown
12.05%

15.66%

aOnaEn
moo®»
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9 Select Design>Preview from the menu bar.

The graph looks like this.

Expense Breakdown

13.71% 10.84%

Administration
Fees

R&D

Sales & Marketing

Services

[
]
=
m|m

Pie seems to be a good style for showing the data so you will not
change the graph style again.

This is what the report with the graph looks like now.

3/19/98
Expenses for 1995 Page 1 of 3
Amount
in thousands Expense Breakdown
Administration
o 381 1371% 10.84%
Q2 402
Q3 412 Bl Administration
Q4 467 BEE Fees
—_— M reD
1662 [ Sales & Marketing
Fees EA services
a1 101
Q2 93
Q3 129
Q4 145

468
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Print the graph (report)

Print the graph (report)

Where you are

Open the report to contain the graph
Create the basic graph
Preview the graph
Save the graph (report)
Enhance the graph
> Print the graph (report)

1 Make sure you are still previewing the graph.
Select File>Print from the menu bar.

The Print dialog box displays.

Il Pages in Range

2 Click OK to accept the defaults and print the report.

Your report goes to the printer or the print queue.

Click the Preview button.

You return to the Report painter workspace.
4 Select File>Close from the menu bar.
If you haven’t saved all your changes, a message box displays to see if

you want to save changes.

5 Click Yes (if the message box displays).

This closes the Report painter.
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CHAPTER 8 Environment Tutorial

You use the Environment painter to manage forms, reports, queries, and
pipelines. In the Environment painter you can:

¢ Open forms, reports, queries, and pipelines, and go automatically
to the appropriate painter

¢ Create a new library and set the current library
¢ Copy, move, and delete forms, reports, queries, and pipelines

In this tutorial you will learn how.

Other things you can do in the Environment painter

¢ Package forms and reports into an application, which you will do
in the next tutorial

¢ Identify query libraries and style libraries, which you can read
about in the InfoMaker User’s Guide

How long will this tutorial take?
About 30 minutes.
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Open forms, reports, and queries

Open forms, reports, and queries

180

Where you are

> Open forms, reports, and queries
Create a new library and set the current library
Copy forms, reports, and queries
Create a new report from an existing one

You need a blank formatted diskette
Before you begin, make sure you have a blank formatted diskette.

First you will learn about using the Environment painter to open forms, reports,
and queries. When you open one of these, you automatically go to the
appropriate painter. (This is also true for pipelines, but you do not work with
pipelines in this tutorial.)

If you have not installed the Form painter
A few of the steps in this tutorial and the next one refer to forms. Just skip
those steps. You will be able to do the tutorials without the forms.

1 Click the Environment painter button in the PowerBar.

InfoMaker e

The Environment painter workspace displays. It lists the forms,
queries, reports, and pipelines in the current library. When you install
InfoMaker, the current library is the InfoMaker sample library
(TUTOR_IM.PBL).

The list includes many samples as well as the form, query, and reports
you created earlier.

Showing dates in the Environment painter

You can show dates for the items listed in the Environment painter. To
control the display of dates, select Design>Modification date from the
menu bar.
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| RS amtenance This form updates my contact table.
- customet_details Sample: Master/detail many-to-one form. The master part is a kist of company names and IDs. Select a c«
B customer_list Sample: Grid form. Uses the Customer table. Has two computed fields (customer count and date) and a
- customer_maintenance Sample: Freeform form. Uses the Customer table. Has one computed field (a date]. Also groups objects
BB departments_and_their_employees Sample: Master/detail one-to-many form. The Department table is the master table; the Employee table i
B8 employee_data Sample: Freeform form. Uses all columns from the Employee table.
23 pipe_emp_table_extatt_newname Sample: Data pipeline that creates a new employee table in the Powersoft Demo DB with the name
!’ q_expenses This query retrieves financial data from the fin_data and fin_code tables. The query selects expense o
what_your_customers_are_ordefing ~ Sample: Query that retrieves data from the Customer, Sales Order, and Product tables. Includes the Sa
Sample: Demonstrates the color and underline attributes by highlighting birthdays of employees that fall i
Sample: Demonstrates the crossout and visible attributes by highlighting empl s whose status is On L
Sample: Demanstrates rotation of objects for various rotation angles.
Sample: Demonstrates changing the font height attribute of text.
Sample: Demonstrates changing the display format attribute of a column. The word Underpaid replaces
attrib_graybar_emp_total_comp Sample: Demonstrates using graybar effect on every other row.
attrib_italic Sample: Demonstrates using italic font to highlight information.
Sample: Demonstrates rotating 3 column headers.
Sample: Demonstrates light gray shading and borders and visible text elements: Due this month, Due ne:
Sample: Ds hanging the di ions and location of objects.
Sample: Composite style report that holds ite_product_sales, »_products, and

Double-click the form contact_maintenance, which is the form you
created earlier.

The form displays in the Form painter. Accessing your form by double-
clicking its name in the Environment painter is the same as opening the
form in the Form painter.

contact_
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Open forms, reports, and queries

3 Select Design>Run from the menu bar.

Your form runs.

L €© Maintain

Larry

Dorothy ___{Customer support
Rose Finance

Beth Product development

Gene Training
Marketi
Mol Sales
Docu

Click the Close button in the PainterBar.

You return to the Form painter workspace.
5 Select File>Close from the menu bar.
You return to the Environment painter. Now you will look at some

other forms.

6 Double-click the form customer_maintenance.
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7  Select Design>Run from the menu bar.

This form is for maintaining customer information.

Click the Close button to return to the Form painter workspace.
Select File>Close from the menu bar to return to the Environment
painter.

Now you will open two reports.

9 Double-click the report emp_total_compensation (scroll the list).

= emp_name_tags
emp_nup_salary_benefits
emp_telephone_attributes

521 employee_grouped_salary
[} expenses
expenses_graph
printer_sales
tabular_orders

The report displays in the Report painter.
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Open forms, reports, and queries

10 Select Design>Preview from the menu bar.

al_compens

Total C ion Report s Fam1atd

Salary Plus Benefits o

Evgayoe
Arst Same Last e

100 102 Ran Wby 345700 o]

1Y

1993939998

11 Use the PAGE UP and PAGE DOWN keys and the scrollbar to see more
data.

12 From the Window menu, select Environment-TUTOR_IM.PBL.

You return to the Environment painter. The emp_total_compensation
report is still open.

13 Scroll the list of reports and double-click the report attrib_start_date.
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14 Select Design>Preview from the menu bar.
Use the PAGE UP and PAGE DOWN keys and the scrollbar to see more

data.
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Now you have two reports and the Environment painter open. All three
are listed at the bottom of the Window menu.
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Open forms, reports, and queries

15 Select Window> Vertical from the menu bar.

The Environment painter and the two reports display. Sometimes it’s
useful to have multiple windows. And you can tile windows vertically
or horizontally, cascade them, or layer them depending on your
preferences.

it - attrib_start_date
q_expenst
what_your_customers_are_ordering
attrib_birthdays
attrib_crossout_and_visible

EZ attrib_escapement_rotation
attrib_font_height

9/16/97 attrib_format

attrib_graybar_emp_total_comp

Department Em
D D

400 attrib_xy

E composite_base
composite_product_sales
composite_products
composite_sales_reps
contact_n_up
contactgrid
contacts_by_jobrole
customel ith_nested_orders

For now you will close the two reports and leave the Environment
painter open.

16 Click the painter close button (X)of each of the two reports.

The two reports close.
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17

Select Window>Layer from the menu bar.

The Environment painter window becomes full size.

| g? q_expenses This query retrieves financial data from the fin_data and fin_code tables. The ery selects expense rows 4
& what_your_customers_are_ordering  Sample: GQuery that retrieves data from the Customer, Sales Order, and Product tables. Includes the Sales
[ attrib_birthdays Sample: Demonstrates the color and underline attributes by highlighting birthdays of employees that fall in.

[7]

= attrib_crossout_and_visible Sample: Demonstrates the crossout and visible attributes by highlighting employees whose status is On Le_

attrib_escapement_rotation Sample: Demonstrates rotation of objects for various rotation angles.
' % attrib_font_height Sample: Demonstrates changing the font height attribute of text.
@ attrib_format Sample: Demonstrates changing the display format attribute of a column. The word Underpaid replaces
@ atirib_graybar_emp_totai_comp Sampie: Demonstrates using graybar effect on every other row,

attrib_italic Sampie: Demonstrates using italic font to highlight information.
attrib_rotate_emp_tatal_comp Sample: Demonstrates rotating 3 column headers.

ib_start_date Sample: Demonstrates light gray shading and borders and visible text elements: Due this month, Due nex

attrib_xy Sample: Demonstrates changing the dimensions and location of objects. E
={ composite_base Sample: Composite style report that holds composite_product_sales, composite_products, and composite:”
composite_product_sales Sample: Used in the composite_base report. Tabular report on product sales. .
composite_products Sample: Used in the composite_base report. Tabular report on products and current inventory.
composite_sales_reps Sample: Used in the composite_base report. Tabular report on product sales representatives and the nun.
=4 contact_n_up Sample: N-up showing four contacts across the page. For each contact, last name, first name, phone, ai
contactgrid Tutorial: Used for Tutorial. Added to a form in the Form painter.

E @ contacts_by_jobrole This report shows my contacts grouped by job role.
| customers_with_nested_orders Sample: Customer information and a nested report, related to the current customer, that shows all orders
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Create a new library and set the current library

Create a new library and set the current library

188

Where you are

Open forms, reports, and queries

> Create a new library and set the current library
Copy forms, reports, and queries
Create a new report from an existing one

Now you will create a new library on a diskette so you can copy some items
into the library.

1 Insert a blank formatted diskette into your diskette drive.

The first thing you will do is to create a new library on the diskette.

About InfoMaker libraries

InfoMaker uses special libraries to hold forms, reports, queries, and
pipelines. These libraries have the file extension PBL. When you save
(or copy or move) a form, report, query, or pipeline, it goes into a PBL
file (pronounced pibble).

2 Select File>New from the menu bar.

The Select Library dialog box displays.



Chapter 8 Environment Tutorial

Change drives to the diskette drive and type the library name
mylib.pbl.

Click Save.

InfoMaker creates the library and opens it. The library is empty.

| Envionment- MYLBPBL

You are going to change back to TUTOR_IM.PBL so that you can
copy objects.

Select File>Open from the menu bar.

The Select Library dialog box displays. It lists all the libraries in the
current folder. You change current libraries by changing to the folder
that holds the library you want to be current and then selecting the
library.
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Create a new library and set the current library

190

Change drives back to the hard drive.
Change to the Tutorial folder.
Select tutor_im.pbl and click Open.

B2 customer_details
{ B customer_list
R customer_maintenance
{ BB departments_and_their_employees
B employee_data
25 pipe_emp_table_extatt_newname
{&P q_expenses
ﬂ what_your_customers_are_ordering
attrib_birthdays
attrib_crossout_and_visible
=4 attib_escapement_rotation

| atiib_format

; attrib_graybar_emp_total_comp
attrib_italic
attrib_rotate_emp_total_comp
attrib_start_date
attrib_zy

= composite_base

somnasite, aroduc)

Now you are back in TUTOR_IM.PBL.

This form updates my contact table.
Sample: Master/detail many-to-one form. The master patt is a list of company names and IDs. Select acc
Sample: Grid form. Uses the Customer table. Has two computed fields (customer count and date) anda ¢
Sample: Freeform form. Uses the Customer table. Has one computed field (a date). Also groups objects w
Sample: Master/detail one-to-many form. The Department table is the master table; the Employee table
Sample: Freeform form. Uses all columns from the Employee table.
Sample: Data pipeline that creates a new employee table in the Powersoft Demo DB with the name
This query retrieves financial data from the fin_data and fin_code tables. The query selects expense rows
Sample: Query that retrieves data from the Customer, Sales Order, and Product tables. Includes the Sal
Sample: Demonstrates the color and underline attributes by highlighting birthdays of employees that fall in
Sample: Demonstrates the crossout and visible attiibutes by highlighting employees whose status is OnlLs
Sample: Demonstrates rotation of objects for various rotation angles.
Sample: Demonstrates changing the font height attribute of text. -
Sample: Demonstrates changing the display format attribute of a column. The word Underpaid replaces a
Sample: Demonstrates using graybar effect on every other row. .
Sample: Demonstrates using italic font to highlight information.
Sample: Demonstrates rotating 3 column headers.
Sample: Demonstrates light gray shading and borders and visible text elements: Due this month, Due nex
Sample: Demonstrates changing the dimensions and location of objects.

: Composite style report that holds composite_product_sales, composite_products, and composite;
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Copy forms, reports, and queries

Where you are

Open forms, reports, and queries

Create a new library and set the current library
> Copy forms, reports, and queries

Create a new report from an existing one

Now you will copy a form, a query, and two reports onto the diskette. Then you
can give them to another InfoMaker user. That user can then use and/or modify
them. Remember that the other user must also be able to access the database.

All InfoMaker users have SQL Anywhere and the contact table. That means
other InfoMaker users can run the form, query, and reports you have created in
this tutorial.

1 (Scroll the list in the Environment painter as necessary.)
Click contact_maintenance.
Press CTRL and click q_expenses.
Press CTRL and click contactgrid.
Press CTRL and click contacts_by_jobrole.
Press CTRL and click d_dddw_states.

The five objects you selected are highlighted. You can copy, move, or
delete them. You are going to copy them to the diskette.

Why you include the report named d-dddw_states

The contact_maintenance form uses a DropDownDataWindow edit
style for the state column. That edit style uses the report named
d_dddw_states, which must be present in the library when you run the
form.

If you create a new library for objects you create using the Powersoft
Demo Database, you need to copy the eight reports that begin with
d_dddw from the TUTOR_IM.PBL to the new library. These reports go
with the DropDownDataWindow edit styles that the tables in the
Powersoft Demo Database use.

There’s a way to make the reports centrally available, as described in the
InfoMaker User’s Guide.
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Copy forms, reports, and queries

192

Click the Copy button in the PainterBar.
The Select library dialog box displays.

Change drives to the diskette drive.
Select mylib.pbl.
Click Open.

InfoMaker copies the selected objects onto the diskette. It takes a
minute or so. You can see messages about the copying at the bottom of
your screen.

Select File>Open from the menu bar.

The Select Library dialog box displays.

Select mylib.pbl.
Click Open.

The Environment painter lists the contents of MYLIB.PBL, the current
library.

onment - \MYLIB.PBL

SR EMIENETEREREE T his form updates my contact table. =

3 g q_expenses This query retrieves financial data from the fin_data and fin_code tables. The query selects expense rows and sorts rov. -
@ contactgrid Tutorial: Used for Tutorial. Added to a form in the Form painter. .

| @ contacts_by_jobrole This report shows my contacts grouped by job role.

] d_dddw_states Report for DropDownD ataWindow: Grid: State ID, State Name, Country
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Create a new report from an existing one

Where you are

Open forms, reports, and queries
Create a new library and set the current library
Copy forms, reports, and queries

> Create a new report from an existing one

Now you will create a new report from one of the reports on the diskette. Then
you will make a slight modification to the report.

The modification adds powerful options to the report that you can see when
you run the report.
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Create a new report from an existing one
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1

Double-click the contactgrid report.

" Environment - \MYLIB PBL .

B  This form updates my cont lhl

: act_main
‘9 q_expenses This query retrieves financial data from the fin_data and fin_code tables. The quely selects expense rows and soits ro
ﬁ contactgrid Tutorial: Used for Tutorial. Added to a form in the Form painter.
contacts_by_jobrole This report shows my contacts grouped by job role.
. d_dddw_states Report for DropDownD atawindow: Grid: State ID, State Name, Country

You go to the Report painter with the contactgrid report open.

Report - contactgrid
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Select File>Save As from the menu bar.

The Save Report dialog box displays. You are going to change the
name of the report so that you can keep the old one and create a new
one with some changes.

L Save Report

DY}
|_dddw_states

Type the name contactgrid_with_prompting and click OK.

The report name changes in the workspace. You are now working on a
report called contactgrid_with_prompting.

B§ Reporil - contactgnd_with_prompting
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Create a new report from an existing one

4 Select Rows>Prompt for Criteria from the menu bar.

The Prompt For Criteria dialog box displays. It lists all the columns in
the report. You can choose one, many, or all columns. The columns
you choose here let you control what rows are selected when you run
the report.

For example, if you choose the city column here, you can specify a city
when you run the report. Then only rows that include that city will be
retrieved.

5 Click each of the columns until they are all highlighted.
Click OK.

You are choosing all columns so that you can enter criteria for any
column you want when you run the report.

; Prompt For ‘Cul.elvla
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Select Design>Preview from the menu bar.

The Specify Retrieval Criteria dialog box displays. Since you said that
you wanted to be prompted for all the columns, the dialog box includes
all the columns.

specify Retrieval Criteria

Click in the first cell in the title column.
Use the horizontal scrollbar to move the title column into full view.

A box with an arrow displays to show there is a dropdown listbox for
that column.

Click the arrow to open the listbox.

Select Customer support.

This puts Customer support in the title column. This means that the
report will be limited to contacts in Customer support.

Administration
ustomer support
Documentation
Finance
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Create a new report from an existing one

10 Click OK.

The report displays. It includes only contacts in Customer support.

Report - contactgrid_with_prompting

Last Name_[First Name Street | Cty | State Zip |  Phone

i Dorgth 54 Minuteran Dr._Lincoln MA 01742 i(508)555-3925
Lyman

Thomas . IEmeryvile _|CA 194603 610)666-6378

Customer support 3 Linden'st.
Customer support 1 Newton St.
‘Customer support |

01720 _{(508)565-2998
30339 _(404)555-5111
01803 _(617)565-1199
30339 {(404)555-7833

By setting up a report to prompt for criteria, you give yourself a lot of
power and flexibility when you run the report. You will learn more
about this when you create an application in the next tutorial.

11 Select File>Close from the menu bar.
When prompted to save changes, click Yes.

The Report painter closes and you return to the Environment painter.
You may notice that your new report does not appear in the list.

12 Select Design>Refresh from the menu bar.

Now your new report is listed. It’s a good idea to add comments to
document the report. You can do that now.

13 Position the pointer on contactgrid_with_prompting.
Press the right mouse button.

The popup menu displays.
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14 Select Modify Comments.

The Modify Entry Comments dialog box displays. If the entry already
had comments, you would be able to edit them. This entry has no
comments yet, so you will enter one.

15 Type This report lets me enter selection criteria when | preview the
report.

L Modify Entry Comments

his report lets me enter selection criteria when |
preview the report.

16 Click OK.
The newly added comment displays.

Now you have become familiar with most of the activities you can do
in the Environment painter except for creating applications.

17 Continue directly to the next tutorial, the Application tutorial.
(Leave the Environment painter open.)
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CHAPTER 9

Application Tutorial

An InfoMaker application is a collection of related reports and forms. For
example, the Contacts application that you will create in this tutorial has:

¢ A form to maintain data in the contact table
¢ A report to list all contacts

¢ A report to list only contacts that meet your criteria

(§17)55523%
6175552245
(310) 5554533

(4045557833
(4045552239
(6175558883

B850
€17)55%2
(3105551233

4045554291
(4045558111
(617) 5554439

How long will this tutorial take?
About 30 minutes.
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About the application

About the application

You will create an application, complete with toolbars and menus. You will
create a shortcut for the application. Then you can run it from your desktop, just
the way you run InfoMaker or any other application.

> Report - contactgrid_with_prompt

Id | Last Name :First Name Job Role Street
5 Sullivan Dorothy  {Customer support 54 Minuteman Dr_
12 iLyman Thomas  |Customer support 64 Story Rd.
16 {Lencki John Customer support 208 Brook Road
18 |Hayne {William Customer support 88 Cornfield Ave.
21 |Cobb {Paul Customer support 34 Greenville St.
22 |Googin iKevin Customer support {88 East Main St.
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Create the application

Where you are

> Create the application
Create a shortcut to the application
Start the application
Use the Data button
Use the By Job button
Use the Ad Hoc button

The application you create will consist of an executable file and an
initialization file. The initialization file provides information about the
database to the executable file.

For example, InfoMaker itself is an application that has an executable file
called im60.exe. This is the file you start running when you start InfoMaker.
InfoMaker also has an initialization file called im.ini.

Terms
The executable file is also called an EXE file (pronounced exxy). The
initialization file is also called an INI file (pronounced inny).

Make sure you have the diskette
Before you begin, make sure you have the diskette from the previous
tutorial in the diskette drive.
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Create the application

204

If you are continuing from the previous tutorial, go to step 2.
Otherwise, go to the Environment painter with the diskette in the
drive and the library named mylib.pbl open.

The Environment painter workspace shows the contents of
MYLIB.PBL.

nvironment - \MYLIB PBL

contact_maintenance This form updates my contact table.
iq =43 q_expenses This query retrieves financial data from the fin_data and fin_code tables. The query selects expense rows andsoi
B contactgrid Tutorial: Used for Tutorial. Added to a form in the Form painter.
AR This report lets me enter selection critetia when | preview the report.
contacts_by_jobrole This report shows my contacts grouped by job role.
@ d_dddw_states Report for DropDownD ataWindow: Grid: State ID. State Name, Country

Now you will select the form and reports for your application.

Click contact_maintenance if it is not already highlighted.
Press CTRL and click contactgrid_with_prompting.
Press CTRL and click contacts_by._jobrole.

The selected items are highlighted.

| Envionment - \MYLIB.PBL
rtact_maintenance This form updates my contact table.

: 58 q_expenses This query retrieves financial data from the fin_data and fin_code tables. The query selects expense rows and so
| contactgrid Tutorial: Used for Tutorial. Added to a form in the Form painter. -

B& contactand Rl This report lets me enter selection criteria when | preview the report.
e This report shows my contacts grouped by job role
Report for DropDownDatawindow: Grid: State 1D, State Name, Countiy
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Click the Create Executable button in the PainterBar.

The Create Executable dialog box displays. In this dialog box you will
specify a title for the application window, a filename for the executable
file, the folder for storing the executable file, and an icon for the
application.

Type Contacts in the Executable Title box.

Later, when you run your application, the title bar will display the word
Contacts.
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Create the application

5 Type contacts.exe in the Executable File Name box.

This assigns a name to your executable file.

6 Click the Browse button next to the Executable Icon box to select
an icon for your application.
Change to the Tutorial folder (the icon is there).

The icon will display in the Windows 95 shortcut. You will create one
shortly.

7 Click Emp.ico.
Click Open to accept the emp.ico file as the icon for your
application.

You return to the Create Executable dialog box. The icon and its full
name display.
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Click Next to define the toolbar items.

The Executable Items dialog box displays. It lists the form and reports
to be included in your application. The information you enter in the
boxes to the right of the list of items is for the currently selected item.

|_with_prompting
ontacts_by_jobrole

Finish defining all information before you click Finish

Do not click the Finish button or press ENTER until you have finished
defining information for all the items you want to include in the
application’s toolbar. Once you click Finish or press ENTER, InfoMaker
generates the executable file.

If you create the executable file before you mean to, select one of the
reports and click the Create Executable button again. InfoMaker
remembers what you have specified already. You can continue where you
left off and recreate the executable file.
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Create the application

9 Click the Text box.
Type Data.

This provides text for the button and for the menu item that will run
contact_maintenance in your application.

xecutable Items

contactgid_wkh_pmpting
contacts_by_jobrole

10 Press TAB to move to the MicroHelp box.
Type Maintain contact information in the database.

This provides MicroHelp for the button and menu item.

ntact information in the databas
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11 In the Picture box, click the arrow on the right end of the box to
display the listbox.
Select the entry Arrangelcons!

This selects the picture for the button, which will be in the application’s
toolbar.

 Executable Items

3 benarc e
ontactgrid_with_prompting
ontacts_by_jobrole

12 Click contactgrid_with_prompting.
Click the Text box and type Ad Hoc.
Press TAB to go to the MicroHelp box.
Type List contacts that meet the specified criteria.
In the Picture box, display the list and select CheckStatus!.

xecutable Items

ontact_maintenance
tar h r
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Create the application

13 Click contacts_by_jobrole.
Click the Text box and type By Job.
Press TAB to go to the MicroHelp box.
Type List all contacts grouped by job role.
In the Picture box, display the list and select Cascade!.

Now you have finished providing information for the form and the two
reports that will be in your application.

14 Click Finish.

InfoMaker creates the application, which consists of an executable file
and an initialization file. These files are in the Tutorial folder.

Now that InfoMaker has finished creating the application, you return to
the Environment painter.

Before leaving the Environment painter, you will open
TUTOR_IM.PBL again. This is where the samples and the tutorial
work are kept.

15 Select File>Open from the menu bar.

16 Select the Tutorial folder.
Select Tutor_im.pbl.
Click Open.

The Environment painter lists the contents of TUTOR_IM.PBL again.

17 Select File>Exit from the menu bar.
InfoMaker closes.
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Create a shortcut to the application

Where you are

Create the application

> Create a shortcut to the application
Start the application
Use the Data button

11 tha Dy lal bddds s
USée ine by v00 oution

Use the Ad Hoc button

Now you will make the application easy to access. To do this you will create a
shortcut on the Windows 95 desktop.

If you are using Windows 3.1
Instead of creating a shortcut, you can add the application to the Powersoft
Program Group (or another program group).

1 Move the pointer to an empty area of the desktop and press the
right mouse button.

The popup menu for the desktop displays.

2 Select New and then Shortcut.
The Create Shortcut dialog box displays.
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Create a shortcut to the application

3 Click the Browse button to locate contacts.exe.
In the Browse dialog box, change folders to the Tutorial folder.
Select contacts.exe and click Open.

You return to the Create Shortcut dialog box with the full path of the
contacts.exe file in place.

4 Click Next.
The Select a Title for the Program dialog box displays.

5 In the textbox, type Contacts over the name offered as a default
(contacts.exe).

This provides a better title to display under the icon on the desktop.

6 Click Finish.

Windows 95 creates the shortcut to your application and displays it on
the desktop. Now you must modify a property of the shortcut so that
you can run your application.
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7 Move the pointer to the icon and press the right mouse button to
display the popup menu.
Select Properties to display the shortcut’s property sheet.

P I e

ontacts Properties

8 Select the Shortcut tab and type the location (path) of the Powersoft
system modules in the Start in box:

About the location of Powersoft system modules
When you install InfoMaker, the installation process automatically puts
the DLLs in a system folder.

For Windows 95 and Windows NT 4.0, the folder path is c:\Program
Files\Powersofi\Shared.

For Windows NT 3.51 and Windows for Workgroups, the folder path is
c\pwrs\shared.

If you have changed the names of the folders used for installing, you will
need to use your names in this step.

9 Click OK.

Windows 95 modifies the shortcut to your application. This
modification enables Windows 95 to find some InfoMaker modules
(DLLs) required for running your application.
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Start the application

Start the application

214

Where you are

Create the application

Create a shortcut to the application
> Start the application

Use the Data button

Use the By Job button

Use the Ad Hoc button

In this section you will start the application you created and take a look at its
toolbar, MicroHelp, and menus.

1 Double-click the Contacts icon shortcut on your desktop.

Your application runs. Don’t be surprised if it takes a minute to get
everything running. The database itself has to start up so that you can
access data.

The main window of the Contacts application displays.
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Notice the toolbar.

The Reports, Forms, and Exit buttons are automatically included. The
Data, By Job, and Ad Hoc buttons are in the toolbar because you
defined them when you created the application.

Move the pointer to one of the buttons.

Notice the MicroHelp at the bottom of the screen.

Click the Objects menu item.

Notice that Data, By Job, and Ad Hoc are included in the Objects
menu. Your application has a toolbar and a menu. You can run forms
and reports from either place.
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Use the Data button

Use the Data button

Where you are

Create the application
Create a shortcut to the application
Start the application
> Use the Data button
Use the By Job button
Use the Ad Hoc button

Now you will use the Data button to run your form. You will add a new contact
and change information about an existing one.

1 Click the Data button.

Your form displays. Notice that title bars identify your application and
the particular part you are using. You also have the usual form toolbar
that lets you view, add, and update information in the database.

2 Click the Add a contact button in the form.
A blank form displays.
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Enter information for a new contact.
Use 62 for the Id entry and make up the rest.

Be sure to fill in all blanks (the only columns you can skip are
phone and fax; the other columns are defined as required in the
database).

Use the TAB key to move from box to box.

Click the Save changes button in the form.
Your new contact goes into the database. You will see it shortly.

Next you want to display information on the contact with Id 37 so you
can make a correction.

About updating the database and canceling changes

You can click the Update button to update the database immediately.
Or you can wait until you'close the form; InfoMaker prompts you to
see if you want to update the database.

Cancel Changes on the Rows menu cancels any changes you’ve made
since the last time you clicked Update.
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Use the Data button

5 Click the Criteria button to display a blank form for setting retrieval
criteria.
Type 37 in the /d box.

This sets the retrieval criteria.

ntact Information

Product development
Administration

Product development
Training i
Markefing

6 Click the Apply button.

This applies the retrieval criteria. InfoMaker retrieves the row with the
Id 37.

Product development
Training

Marketing

Sales

7 Change the Street to 134 Cherry St.
Click the Save changes button in the form.

Your changes are added immediately to the database.
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10

Click the Next button.

A message box displays because you have set criteria that allow only
row number 37 to be retrieved. You need to remove the criteria or
specify other criteria.

Click OK to close the message box.

Click the Criteria button.

Select 37 and press the DELETE key to delete 37 from the /d box.
Click the Apply button.

Now you have no criteria, so InfoMaker retrieves all rows.

Select File>Close from the menu bar.

Your form closes.
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Use the By Job button

Use the By Job button

Where you are

Create the application
Create a shortcut to the application
Start the application
Use the Data button
> Use the By Job button
Use the Ad Hoc button

Now you will run a report of all contacts grouped by job role.

1 Click the By Job button.
The report that lists all contacts grouped by job role displays.

Report - contacts_by_jobrole

My Contacts

Michae! (617) 555-2338 (617) 555-3337
MaryBeth (617)555-1193 (617) 555-9586
Temy (617) 555-2246 (617)555-3692
John (310) 555-4533 (310)555-1233

(4045552233 (404) 5558111
6171555:4439

2 Scroll the report to see your new contact.
When you’ve finished, select File>Close from the menu bar.

Once again you return to the main application window.
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Use the Ad Hoc button

Where you are

Create the application
Create a shortcut to the application
Start the application
Use the Data button
Use the By Job button
> Use the Ad Hoc button

Now you will use the Ad Hoc button to run several different reports based on
the criteria you specify.

1 Click the Ad Hoc button.

The Specify Retrieval Criteria dialog box displays. This dialog box
displays because you selected Prompt for Criteria for this report.
Whenever you run this report, you are first prompted for criteria.

221



Use the Ad Hoc button

2 Click OK.

Because you didn’t specify any criteria, the report retrieves all your
contacts.

id | Last Name |First Name| Job Role Street | Cty | i Phone
Hidebrand _|Jane 1280 Washington StiEmeryvile M (510)555-1309
{Simmon Larry le 34 Granville St. Houston (713)555-8960
Isusan 145 Center St. Danvers (508)556-4829
Terry 204 Page St Canton (617)555-2246
Dorothy J y 54 Minuteman Dr. :Lincoin (508)565-3925
i 78 Bay St iMarblehead (617)555-6392
44 03k St Lexington (617)555-0273
562 West Main St._iLexington (617)555-3528
68 Red Acre Rd. _jLexington (617)565-3528
55 Pine Grove Rd. {Lexington (617)555-4325
16 Rainbow Rd. __Burlington (617)565-8474
64 Story Rd. Emeryville
/64 Story Rd. Emeryvile
126 Bri Ter. E&rwme

One Park Drive __ Allarta

3 Select Rows>Retrieve from the menu bar.

The Specify Retrieval Criteria dialog box displays again. This time you
will enter criteria.
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Go to the title column.
Select Documentation from the dropdown listbox.

Click OK.

Documentati

You have specified that the report is to list only contacts who have jobs
in documentation.

| © Report - contactgrid_with_prompting

Id : Last Name |First Name! Job Role Street

1. Wiliam___{Documentafion 16 Rainbow Rd.
29 Joseph Documentation 1112 Center St.

Coleman___:Documentation 7% Dunster PI.

Click the Retrieve button.

The Specify Retrieval Criteria dialog box displays again. Notice that
the criterion in the title column is still in effect. To specify different
criteria, you are now going to delete Documentation. Then you will
enter new criteria.

Specify Retrieval Crite‘r
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Select the documentation entry in the title column.
Press DELETE.

This deletes criteria from the title column. Now you are going to enter
new criteria.

Click in the first box underneath /ast_name.
Type like "c%".
Click OK.

This entry (like "c%") helps you find that name you couldn’t
remember. All you could remember is that it started with C.

The like operator specifies that only rows that match what follows
should be retrieved. The quotes are required. The ¢ means that the first
character must be C. The % sign means any characters can follow the
C.

This is the report.

Last Name_|First Name|  Job Role | Street
|

Critch 3 ct development 145 Center St
Clarke !

St
99 Edison St

27 Rush Rd.
Lincoln Street 01803 (61715651199
. 0339 (404)555-
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8 Click the Retrieve button.

The Specify Retrieval Criteria dialog box displays again. This time the
requirement that the last name begin with C is still in effect. Now you
will add an additional requirement. The report is to list contacts whose
last names begin with C and who are from Burlington.

9 Use the scrollbar to display the city column.
Click in the first box underneath city and type Burlington
Click OK.

e .Hclrieval Criteria

Now the report has only contacts whose last names begin with C and
who are from Burlington.

Report - contactgrid_with_prompting

First Name Street i i Zip

David 16 Waverly Rd. v io1s03 1716853078
108 Park Steet __Burlingi 01803 _|(617)555-8883
01803 (61715551344

01803 _(617)555-0004

01803

10 Click the Retrieve button.

The Specify Retrieval Criteria dialog box displays again. The
requirements that the last name begin with C and that the city must be
Burlington are still in effect.

Now you will change the city requirement slightly. The report is to list
contacts whose last names begin with C or who are from Atlanta. To be
listed, contacts have to meet either requirement; they do not have to
meet both requirements.
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Use the Ad Hoc button

11 Use the scrollbar to display the city column.
Select Burllngton and press DELETE to delete Burlington.

12 Press the DOWN ARROW key to move down one row.
Type Atlanta.
Click OK.

By specifying criteria in two different rows in the dialog box, you are
specifying that the report should retrieve rows from the database that
meet the first row of criteria or the second row of criteria.

Atlanta

Your report retrieves all contacts whose names begin with C. It also
retrieves all contacts who are from Atlanta. It’s hard to look at the two
sets of rows, so now you will sort by city. Then all the Atlanta rows
will be together.

| & Report - contactgrid_with_prompting

City gsme] Zip | Phone
Danvers MA 01923 08)555-4829

30339
Product development 116 . i 01803 |(617)555-3378
Customer support vile St. 30339 E(4o4)55&2239
Customer support i M 01803 i 517)565-8883
[Sales 130339 _(404)555-1169
Crowley 3 {Burii 01803 _i(617)565-1344
i i 01730 _|(617)555-2144
101803

567 Park Dnve
29 Garden St
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13 Select Rows>Sort from the menu bar.

The Specify Sort Columns dialog box displays.
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14 Drag the /d column out of the Columns box and the city column into
the Columns box.

InfoMaker sorts the rows by city. Now you can see the Atlanta contacts
first. These are followed by contacts whose names begin with C.

Street Phone
Peanut Way (404)566-7833
One Park Drive __ jAllanta
567 Park Drive (404)555-1233
29 Garden St. (404)556-6111
(404)566-2239
3 (404)555-1169
Finance o i(617)556-2144
Customer support !
Customer support

Now you are finished using this report and using the application.

15 Click the Exit button.
This closes the report and the application.

Now you have done it all. You created data, maintained it, and reported on it.
And you put all your work together into your own application.
Congratulations.
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See the next page for some suggestions on what to do next.
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What to do next

What to do next
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You may be ready to make your own InfoMaker application or interested in
learning more. Here are some ideas.

Personalize the contact data Delete all the data in the contact table and
add your own. You can run your Contacts application to do this. Use the
form to delete and add data.

Look at other sample forms and reports In the Environment tutorial,
you accessed a few of the sample forms and reports delivered with
InfoMaker. Now you can go back and look at more. The samples are
located in the InfoMaker sample library named TUTOR_IM.PBL. When
you look, notice both the design version and what results when you run a
form or preview a report.

Use the sample pipeline The sample library includes a sample pipeline.
Pipelines let you move data structures and data within and between
databases. Open the library and double-click the pipeline. This takes you to
the Data Pipeline painter. The sample pipeline creates a copy of the
employee table in the Powersoft Demo Database. To create the copy, you
execute the pipeline.

Change sample forms and reports If you want to try some changes with
samples, open the form or report and use Save As on the File menu. With
Save As, you create a copy of the form or report and save it with a new
name. Then you can make changes without affecting the original.

Create other forms and reports using the Powersoft Demo Database
Once you’ve looked at the sample forms and reports, try creating some on
your own. The Powersoft Demo Database has several tables that you can
use. You may want to start with the Contact table since you are so familiar
with it. Use the other InfoMaker documentation and online Help as you
work.
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